Pro Tools can't find Virtual Midi Port

Hi there!

Pro Tools for some reason doesn't show the Virtual Bome Miditranslator Input Port, to select as incoming port for the HUI Midi Device. But the Virtual Output Port is visible. And when i start the app pocket midi, i can select the virtual input port and it shows midi messages. Is there some setting wrong?

best, henrik


Are you on Windows or Mac? At the time you are using ProTools, are you also using another MIDI application? On Windows, applications cannot share MIDI ports (virtual or otherwise) although they should still be able to see them.

Also look to see if you can find it under the short name (if MT Pro is using shortnames). It may show up as “BMT 1”.

With that said, if other apps can see Bome Virtual port and use it, the issue must be within the app that cannot.

Also, if you are on a Mac, make sure also you start up Bome MT Pro first before opening ProTools as on Mac MT Pro only exposes virtual ports when it is running.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist



Hey Steve,

thanks for your answer! sorry i’m working on a mac, OSX 10.3.4. the funny thing is, that when i leave the peripherals -> Midi Controllers settings dialog in protools open, and in MT in preferences -> virtual ports I change the number of virtual ports, and switch back to pro tools, the “Send To”-droptown menu takes over the changes. When i set it in MT to two virtual ports, i can choose from two virtual ports in the “send to” menu. But no MT option in the “Receive From” menu.

I recently installed Avid EUCON to control Pro Tools with an Ipad, maybe that caused the problem? I uninstalled EUCON and rebooted, but still no “Receive From” MT in Pro Tools..

cheers, henrik

Hi, if you see the virtual ports in other applications then the issue is likely with Pro Tools. Check with Avid. Also maybe the EUCON app didn’t fully uninstall if that was what seemed to trigger the issue.

If you don’t see virtual input ports on Pocket MIDI either then there might be an issue with MT Pro.

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist

hey, ok thanks!

Hi Henrik,
Did you ever find out what the problem was?

Hi Steve! not yet. i got the tip that Eucon and HUI cancel themselves out, or they block themselves. Avid Support (indeed answered) sais to try other midi ports and update my OSX. i will try in the next days!

OK, thanks. Would be nice to know.

Hi! the updated ended in osx not supporting my graphics card anymore, screwed up my backup, but i hat an osx system clone from 2 months ago. way before i installed eucon. I istalled it and booted the system, and it still doesn’t work. (in cubase it does). very strange, because on exactly the same system i used to work with it.

Maybe something changed in Pro-tools?

i decided to go a different way, and take the nob control. awsome. works without drivers like a mouse, but you have a knob to turn with direct sensitive touch control for two axes, left/right and up/down. so what you do is take the mouse cursor to any encoder or fader or scroll bar, let go of the mouse and just turn the knob and move it. As long as you hold the finger touched to the device, you adjust the parameter, and with additive finger touch the other axis up/down or left/right. its a small company from greece, allways sold out. no commercial here :) just a recomondation.

Awesome. Yes I think knobs work better than XY pads too!

Hi, make sure in MT Pro you have MIDI settings to short names. Pro Tools doesn’t like long MIDI port names.