Problems with Bomebox as DHCP master

Hi!

I have problems getting my BomeBox to work as a DHCP master and in APIPA mode. What I would like is only one ethernet connection between Bomebox and a laptop with ethernet-adapter, and it seems it should work. My laptop is MacbookPro M1 with Monterey 12.4. The only way I can get it to work with ethernet is with bomebox as client if I also connect it through a switch that also has a connected router with DHCP-server.

In the “network settings” of my mac I immediately get an IP from DHCP when I connect to my router, but when I connect (only) to the Bomebox this never happens (it only makes self assigned IP and can’t find the BomeBox). Wondering if I have missed something. The wifi is also turned off both on the laptop and the Bomebox when I try this.

Hi,

I tried this on my MacBook Pro with a USB to ethernet adapter cable on Monterey 12.4. You need to ensure WiFi is turned off on you BomeBox for it to work properly in APIPA mode. You may need to restart you BomeBox after turning off WiFi. Also your Mac should have WiFi off.

And yes, set it up for DHCP on your Mac to use APIPA mode and it should show yellow with “self assigned”.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Thanks for your reply!

I’ve tried a lot of different ways to connect with ethernet, but I simply cannot get it to work. That includes BomeBox as DHCP master, as DHCP client, in APIPA mode and also with fixed ip. I get short moments of connection, then it’s down again. My macbook ethernet adapter and cable easily connects to everything else, so I don’t think my computer is the problem. Also I’ve tried to connect the bomebox as DHCP client to two different routers with DHCP. Perhaps stupid question, but the “POE in” port is also for data, right?

Wifi works fine, but for live use I don’t trust wifi. One reason is that wifi on my computer can suddenly decide to switch to another network if it detects a known wifi network, and also the bomebox wifi get registered as a default gateway which turns my computer slow as all kinds of services tries to connect.

Maybe it is possible that the advanced network settings got messed up. Try a network reset as described in the BomeBox Instructions and then try again.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Resetting the network settings seemed to solve some of the problems for a short while, then the same issues appeared again. For all ethernet connection options, the connection seems to be very unstable and/or very slow, with short moments of connections before disconnecting again. All wifi options run smoothly. I have tried with different routers, different macs, different ethernet adapters and different cables. At this point I suspect there is a hardware problem.

Some questions:

-for data, can both ethernet connectors be used, both Poe in and out? Do the two connectors have different mac adresses?
-what does the left and right LEDs on both connectors indicate?
-what should the hardware settings for the ethernet connection be if I enter them manually, that is speed, duplex mode etc?

By default they have the same MAC and IP address

From page 27 of the instructions:

PoE In The left LED indicates network activity. The right LED indicates that it is powered via PoE.
PoE Out The left LED indicates network activity. The right LED indicates that PoE power is available for powering another
BomeBox.

You should not need to set them manually. If set manually, you should set them in accordance with the other devices on the network. I fact you should normally not need to go to the advanced settings on any of the pages.

Keep in mind there should be one and only one DHCP master otherwise they may hand out the same addresses and cause all kinds of havoc. In many cases if you have another router on the network, it will be the master in which case you should set your BomeBox as a DHCP client.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I meant manually set the other devices to match the bome box, to see if that helps. On the one router where I can see the speed, the speed was automatically set to 10 Mbps for the port the bomebox was connected to. Does that seem right? Some moments later the port was reported as “down” and there were no activity on the LEDs on the bomebox.

And yes, I make sure there is only one DHCP master at a time on the network.

The BomeBox can handle speeds of up to 100mbps.

When you say that the port was reported down, what tool were you looking at. Were you looking at Bome Network? Are you running both WiFi and ethernet on BomeBox? If so, turn WiFI on your BomeBox off as with both running at the same time the BomeBox will report to separate IP address on the same network and cause switching issues. You should use either WiFi or ethernet at a given time but not both unless you are using the BomeBox as an access point to your ethernet with ethernet set as a DHCP client and BomeBox WiFi using a separate SSID than your home network.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Thanks for you answer, and apologies for slow follow-up, I’m only able to re-visit this issue once in a while.

As for your question, I was looking at the router which reported 10 Mbps, and then “down”. Wifi was turned off on the bomebox.

It seems to me that all attempts to connect by ethernet only works now and then, before it either fails or gets very slow, like the majority of packets gets dropped or something. I’ve tried fixed ip, APIPA and DHCP both master and client, they all seem to work a little bit, or not, or extremely slow with lots of lag. With fixed ip, I get stuck on the page “BomeBox web config loading…” in my browser.

Sometimes the LED indicating traffic is dark when a cable is connected, or is lighting up with nothing connected to it, which is why I’m wondering if there might be a problem with the connection. I haven’t touched the advanced settings at all.

I’m hoping that I’m missing something very obvoius, because it would be really convenient if I got it to work with just the ethernet cable. For now I think I’m sticking with wifi since it seems to be reliable, even if it means bringing an extra wifi router to gigs. I bought the bomebox for live use, which means I need it to be reliable and work immediately when I connect it, since there’s no time to configure or test on a typical soundcheck.

This tells me that the cables are probably OK and that you have a different DHCP master on your network when connected through the switch

This typically happens if more than one device has been assigned the same IP address or that if the project file running has a problem. Are you running a MT Pro project file on your BomeBox? Are you sending or receiving MIDI through your BomeBox? If so, what project file are you using (if any) and how are your routes set). You might want to run the “arp” command on you PC so you can identify everything on your network and compare IP and Mac addresses. I would assume everything gets slow on your network if there are two devices assigned the same IP address. When the slowness occurs, perhaps you can disconnect the other devices one at a time until the speed is recovered.

If you use fixed IP, the IP must be on the same network as your computer and you will likely need to set up your computer for fixed IP as well, or at least ensure the IP you are assigning does not collide with anything else on the network and that it has the same netmask.

I assume you mean the network LED’s. The left LED’s should not light up (except possibly at power up) unless there is a physical cable connected to the network.

My recommendation at this time is to do a network reset. After that, If after that and nothing is connected, make sure the LED’s are off and when connected, blinking. If this isn’t happening, perhaps you have a bad BomeBox and you can come back to us so that we can re-arrange for a replacement. It is important that you do a network reset before all of this just to make sure one of your settings did not get messed up.

My understanding is that the configuration you want for your gigs is that your BomeBox is an ethernet master and acts as a router to connect all other attached devices. Your Macbook and other devices are clients. Beside your MacBook, what other ethernet devices are you attaching?

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi @espenrei, have you been able to resolve this issue?

Hi,

Funny, I was just diving back into this when I saw your message. No, unfortunately it hasn’t been resolved, I’ve been working with the Bomebox with the stable setup which is through wifi. Today I just noticed again the left LED of the right ethernet port is blinking, with no cable attached. I unplugged everything leaving just USB power and did a factory reset through the web panel, which I assume is as effective as a network reset. After it had powered up again the LED was still blinking. I took a video of it in case that’s any help.

so maybe this is a hardware failure on the Ethernet port (and the first time, Ethernet is less stable than WiFi!). We’ve seen an Ethernet failure once before – Ethernet working to some degree, but not stable. The random activity LED may also play a role.

We’ll PM you for replacement options.

Ok, that’s wonderful, thanks for the follow-up!