Project fails to run on Bomebox


I'm having trouble running projects on bomebox, it's failing 90% of times.

I checked Sytem log:

Mon Jun 1 00:41:48 2020 user.crit mountd[1729]: bb: got a autofs packet
Mon Jun 1 00:41:48 2020 user.crit mountd[1729]: kernel is requesting a mount -> sda1
Mon Jun 1 00:41:48 2020 user.crit mountd[1729]: request for invalid path /tmp/run/mountd/sda1
Mon Jun 1 00:41:48 2020 user.crit mountd[1729]: failed to mount sda1
Mon Jun 1 00:41:48 2020 user.notice bomebox: /bome/playerheadless -project /projects/SmartPad_XtchM_mio10_383_140.bmtp
Mon Jun 1 00:41:49 2020 user.notice bomebox: /bome/playerheadless exit code 139: restart

sometimes it's exit code 134: restart

It usualy helps if I do a factory reset and then load/select project and assign all aliases again,

but if I try to load and select another project it all starts acting up again:(

Is there something wrong with my bomebox?

Thanks in advance for any advice.


First make sure your BomeBox is running the latest version.


Without looking at your project setup, it is hard to tell but by the log, it looks like you are trying to run the project from a USB thumb drive. Try a different USB thumb drive (FAT 32 formatted) or simply uploading the project to the BomeBox internal storage. Also, make sure that if running from a thumb drive that it is plugged in when you turn on your BomeBox.  I suspect it may have been told to run a project from a then non-existent thumb drive (because the project you defined may not yet be available).


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:



Steve Caldwell
Bome Customer Care

Also available for paid consulting services:




i'm not running project from tumbdrive, i'm running it from Bomebox internal storage.

My project is about 1.4M and it takes almost 60s to upload to bomebox, and then about 8-9 minutest to start the project,when I select it on web gui. Bomebox iz conected via ethernet cable to Gigaswitch.

I can send you a project file if it wil help to diagnose.

I'm powering Bomebox from usb and I have a powered usb hub conected too.

connected to hub: MidifaceX16, mio10, 2x XtouchMini, Arturia BeatStep, SmartPad and two usb wireless keyboard recievers

I'm runing the latest firmware.


OK, 1.4M is a pretty big project file but if you want to email it to me, I will take a look

(BomeBox has 8M of memory so there shouldn't be any problem unless you have 5 or 6 projects of this size on your BomeBox.


. I have a few that are bigger. Most of what I have are around half that size.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:


Hi, I attached my project file, it's compressed because attachment limit is 1M.

Thank you for help.




OK, other than the mounting sda1 errors and the long time it took to load, I didn't have an issue on my BomeBox.  I suspect the mounting errors are the BomeBox just trying to figure out:

1) Whether to do a network reset if a thumb drive is loaded with the network reset file

2) Whether to do a password reset if a thumb drive is loade with a password reset file

3) Make additional project files from the thumb drive availabel for use on BomeBox.


So, essentially I escalated the issue for resolution


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Just another note: Personally I found the a POE adapter is a more stable option than USB when running my BomeBox. Also I think having a connector with a latch makes it less susceptible to inadvertently getting power disconnected.

This is just my own opinion.


Hi Primozz,
wow, your project looks like a lot of development work. Hats off!

Sorry to read of your problem, though.

I've had a look at it. As you noticed, the BomeBox is not (yet) well prepared for project files of this size. I've just loaded it on a BomeBox under a debugger, and except for the long load time, I could not find a problem. Once loaded, it takes only 30% of RAM, so what you're experiencing is unlikely a memory issue.

While the project file was loading, I did not touch the web config or use any MIDI. That might interfere with the loading process. And, of course, I had not attached all the devices which you use, so maybe that is the crucial difference?

The error codes 134 or 139 you're seeing in the system log are exceptions which occurred during loading, and which caused the firmware to internally restart. Unless I cannot reproduce these exceptions, I cannot find out more about this.

Have you tried loading it without attached devices, and once loaded (~10 minutes), attach them? I know this is not suitable for production use. Just to get a feel if that could be the problem.

The "sda" related errors can safely be ignored. As Steve guessed, it's the MT web config page trying to locate files on a thumb drive. If none is attached, it will post an error to the system log.

We have the plan to allow exporting a project file from MIDI Translator Pro as a compressed file for the BomeBox. That would make the load time much smaller and use much less memory in the BomeBox. Right now, the project file is always loaded entirely into memory (including translator names, comments, etc.). While that increases load time, it certainly should still work with project files the size of yours.

I will run additional tests to see if I can reproduce your problem and get back to you. If you have any other observations or ideas, let me know (here). Thanks!

Hi Florian,

I tried this yesterday:
Powered on Bomebox without usb hub connected, waited for about 6.5 minutes and the project(one that I had loaded and running a day before) succesfully started (at the start of a project Bomebox sends out a CC to OpenStageControl running on virtual machine, so I was able to see exactly when the project started).
Then I connected powered usb hub with all devices powered on and Bomebox recognized them all and I was ready to start playing. Everything worked fine, I was running it for good 12 hours, I did some playing then left it idle and repeated that a few times, no problems whatsoever.

Today I powered on Bomebox but I forgot to disconnect usb hub, so when I noticed it, about 15sec after powering on, I disconnected USB hub from Bomebox.
I waited for 10 minutes, but the project didn't started. Then I started uploading my project(new updated file) to internal storage and when it finished uploading I got:
'Errors: load native settings: settings file vanished. filename:/etc/mt/playerheadless.bmts overriding settings file with backup (native).'
Then I selected the uploaded project from web gui and waited 10 minutes, but it did not start.
I checked the web gui, clicked F5 to refresh page and there was still the above error message, so I decided to make a factory reset, still with no USB devices connected. That took about 80 seconds, then I logged in and set the password. Then I had to confirm network connections for Bomebox#2 (I have a second Bomebox that is running a smaller 5-piece LFO project) and I clicked 'Connect' for the remaining 6 network connections (4 computers and 2 virtual machines running win7 and OpenStageControl server). All connections were done OK.
Then I uploaded new project to internal storage(it took 26s) and selected the project, waited 10 minutes to load and it did. Then I proceeded to plugging in powered usb hub with all devices connected and powered on, and assign all aliases.
Now it's running fine. I played a couple of hours and it's still running ok. Now I powered off Bomebox, disconnected usb hub and waited a couple of minutes, then I turned it on with no usb hub connected, waited ~9 minutes for previously uploaded/selected project to start running, then I reconnected usb hub, Bomebox recognized all attached devices correctly and is now running fine.
Will do some more testing...

about my network connections to Bomebox:
I have OpenStageControl running on 2 virtual win7 machines (named QNABOX7 and OSCBOX7).
I'm sending note number info in form of CC value for all 8 input sources(keyboards, sequencer etc.) and 6 targets(sound generators) to this 2 machines.
Main machine(QNABOX7) is also used as main controller for Bomebox to set arpeggiator parameters, choose scales, transpose, notes routing, remote CC control sound generators and everything else.
Then I have additional 4 PCs that connect to Bomebox and receive some CC commands for desktop switching(3 of this PCs are also running MidiTranslatorPro) the 4th PC is my main computer to which I route all notes massages, pitch-bend and some CC to record in Cubase(haven't yet tested recording, but I have translators outputting messages to this PC over BomeNetwork already - could this be problematic?)
Lately I had some troubles with Bomebox establishing connections to 2 virtual machines running OpenStageControl, at one time there was 40 connections pending for QNABOX7(main controller).

Other observations I've made in last month or two since my project file grew over 1.1M and problems started:
I connected usb power to Bomebox through usb power-meter and when I powered on Bomebox without usb hub connected, it shows about 4.80V / 0.26A, but as soon as I connect usb hub with all devices powered on, the power-meter shows about 4.98V / 0.15A, but all is working fine.
Another thing that happened a few times after selecting project from web gui was that after a few minutes I get 'Gateway error'(or something like it, can't remember exactly) in browser and I can't connect to Bomebox anymore, I have to power it off and on again to be able to connect.
Could this be a power issue? I'm ordering my PoE first thing tomorrow.

Thanks for your time and help!
and for the 'hats off', it made my day:)


Hi, Chiming in again. Good call on ordering POE! I used to have random issues when connecting with USB power but since I got POE for both of my BomeBoxes, things have been rock solid. I'm pretty sure that the POE providing a higher voltage keeps the BomeBox internal 5v that it provides to devices more stable and some USB devices are very susceptible for even slight drops in voltage.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi Primozz,
thanks for the thorough tests and for reporting it all!

So it seems to me that we have some kind of a work-around: load the project file (or start the BomeBox) without the USB devices attached. Then, when fully loaded (project file is highlighted on MT web config page), attach the USB devices. In general, don't touch the BomeBox during load time of the project file...

I believe that you will not need to do a factory reset when experiencing problems. Waiting until the load process is done, and/or power cycling should reset it enough.

The "load native settings" error is inconvenient, but it fully recovered using backup settings. The 'Gateway error' seemed to be a problem with the internal web server of the BomeBox. Maybe the CPU was 100% busy with loading the project file, blocking the web server from responding? I could not reproduce this behavior. If you have that again, let us know.

Last, but not least, you wrote:

I connected usb power to Bomebox through usb power-meter and when I powered on Bomebox without usb hub connected, it shows about 4.80V / 0.26A, but as soon as I connect usb hub with all devices powered on, the power-meter shows about 4.98V / 0.15A, but all is working fine.

If I understand correctly, you measured the voltage going into the BomeBox using the micro-USB connector? Then, the voltage depends on the power supply you're using. Our experience is that most USB power supplies have bad voltage stabilization. They are meant for charging, and there, a stable voltage is not important. Typical behavior is that the more current is drawn, the lower the voltage. And when current changes, voltage will temporarily jump up or down. The BomeBox can handle lower voltages (its CPU uses 3.3V), but jumping voltage can be a problem. And lower input voltage is a problem for powering devices on the USB host port -- but you're using a powered hub, so no problem there.

We have not seen an effect on the input voltage when connecting a powered USB hub. Although some (bad) USB hubs feed power back to the USB host, the BomeBox has some protection against that. Maybe it was that when you connected the USB hub, the BomeBox was done loading the project file and therefore used less current, so that the USB power supply increased voltage?

Let's see if the PoE power supply helps.

Thanks for giving us new challenges for future firmware (and hardware) updates!


I finally got my PoE, been testing it for a few days now and I'm happy to report that all problems with loading projects are gone :) Now I can power on BomeBox with all usb devices connected (powered hub) and it starts OK, takes about 5 minutes to start 1.3M project.




Glad to see that everything is working now!