Set 'pp' to value missing



I am trying to map the rotary knob on an x touch mini, I have followed all the tutorials on youtube, but I am getting stuck on getting the incoming midi message with the "line set 'pp' to value". instead, I get the following in my incoming midi capture.

Control Change on ch. 11 with CC#:1 (0x01) and value:62 (0x3E)


Please help!!!1




Hi, that looks like the MIDI you captured. Once you capture the incoming MIDI into that translator by clicking the message, go to the incoming section (right under where you were) and edit by checking “Any Value” and then right under that, you can add pp into the box that says “set value to”.

Then for output you can use the value pp and it will send what was captured on incoming.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist

Hi Steve, many thanks for getting back to me quickly, That didnt seem to work for me.


I have attached a screenshot of the video tutorial and my screen side by side.





First of all, on your MIDI fighter twister it would be better to change the knob to Enc/Dec since I assume you will want to move mouse right for a twist to the right and left for a twist to the left. That way any right movement of 65 (41 Hex) will move the mouse right and left movement of 63 (39 Hex) you can move the mouse to the left.

Right now you have it set up as an absolute encoder so you would need to use rules to determine if you have an increasing (right) value or decreasing (left value). You can do this with the MIDI Fighter utility. You can also do it using Bome MIDI translator but it will take a few rules.

Secondly if you want to use the value of pp, you will need to click the right twisty arrow until it opens up additional information below it. (See screenshots)

I’ve also attached an example (but with a different MIDI channel and CC ) using a relative encoder on my MIDI Fighter Twister.




I understand how the op feels. I updated yesterday my Bome midi translator pro from version 1.8.0 to 1.8.4 and didn’t see either the “pp” value when capturing incoming midi. After scratching my head a little bit i find that now we need some fews additionals clicks like Mr Steve have shown instead of simply clicking on the incoming pp value message. That’s confusing!

I believe in 1.8.4 the option to capture as pp is now not shown, you can instead capture the incoming value and then substitute the the value of the incoming messages with the local variable.

Also in capture MIDI, you can either capture as raw data which would look like

90 24 7F

or as regular MIDI which would show Like

Note on, Note 36 (0x24) on MIDI Channel 1 value 127 (0x7f)

There is a gear icon above the capture MIDI box that allows you to change between raw capture (the first method) and regular caption (the second method.

Clicking on the desired MIDI message, transfers the item into the incoming trigger of the message.
You can then edit the message with variables instead of absolute numbers.

This is what normal capture looks like:


This is what raw capture looks like:


The drop down menu of the gear box here shows raw capture checked. Simply check it again to uncheck.


Here I’m changing the incoming note number to pp using the raw capture method.

Here I’m doing the same thing but using the normal capture method. There is actually a drop down method to pick the desired variable or you can just type in the variable you want to use if you don’t like to use the dropdown.

I hope this helps!

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:
1 Like

Thanks Mr Steve for this detailed response. Speaking for myself, i knew how to do these configurations, it was just much quicker and easier with the 1.8.0 version. We only had to click once one the “pp” value and all the good parameters were entered. At first it was confusing because my translators didn’t work but then after i figured out the process that you wonderfully explained, all was good. But i revert back to the 1.8.0 version, it’s just more quicker for me because i have many translators entries and less clicking is more welcomedCapture Bome pp value

Yes, I believe that having the option to capture variable values actually confused a lot of users so it was removed. I’ll check and see if I can find out more information.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi, you’re absolutely right. If you know what you’re doing, the 1.8.0 way is a fast way to enter the incoming action with pp. The problem was that it was confusing and I never liked the thing that a capture function produced 3 different entries for the same incoming message. We have had support calls for that and I had to agree that it is confusing – unless you know MIDI and MIDI Translator Pro well enough to understand that the three entries represent the same MIDI input message.
But it should be easy to add a third capture mode where the value is set to pp. I think that should suit you, right?

Yes, that would be awesome.

Three capture modes



Hi Mr Steve and Florian,
Thanks Florian for your explanations, i understand now and yes it would be awesome if we had a third capture mode.
By the the way before i upgrade from 1.8.0 to 1.8.4, i was interrested for the “Start minimised” feature because my BMT pro start when Windows 7 start and i always have to minimize it and i thought that feature was for that case but in reality it’s for when the application was not launched, you launch it and it minimize the window automatically. That’s confusing also! Beacause i was expecting the reverse effect : when i start my computer i want BMT pro to be minimize because i don’t need it openned. And sometimes i make somes tweaks translator entries just to test something then close the app without saving when i finish, then reoppen the app to check if everything is fine as before or do some other testing and in that case i don’t want the app to automatically be minimized when it’s launched. For the moment i revert back to the 1.8.0 version because it suit me better, and i hope to find my way with a future upgraded version. By the way for request also, it would be nice to just foward icoming messages to the outgoing messages port without changing anything.
Thanks again for your awesome software.

I’m a bit confused.

In Startup Options there is a check box to start minimized. This should always work. If you want to start MT Pro when Windows is launched you can add a shortcut to your Startup Folder to do so.
It will always start minimized and you will need to Click the Icon in the task bar to open it up and view it.

There is also an option under appearance to minimize to tray which will instead of putting it in the task bar, but it in the tray. You can then right click in the tray to open and edit the project.

In either case, you will need to save your project file before closing and re-opening as the X button in the right corner is for closing the application (not for minimizing or minimizing to tray).

Start minimize will always start the app minimized whether you open it manually or from automatically from the startup folder. I’m not clear on what conditions you want it minimized automatically and what conditions you don’'t and I’m not sure we could differentiate.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks again for the quick reply!
I checked the start minimized box when i upgrade to 1.8.4. I must precise also that i directly installed that version without uninstalling the previous 1.8.0 version. So maybe it was a conflict between to two because i remember after checking the"start minimized" box, restarting my pc and still having BMT pro window opened and not minimized. Also after reverting back to1.8.0 when i restart my pc, i got 2 BMT pro windows openned. I suppose i have to uninstall one of them. (I didn’t noticed the minimized to tray feature in 1.8.4, that’s a nice addition, thanks).
For clarification i want the app to be automatically minimized at Windows 7 startup but when i’m lauching it manually to be not minimized automatically. I thought it was possible to differenciate the very first launch from Windows 7 startup (minimized in that case) from the next manual launches (not minimized in that case).

It is possible that each version of MT Pro was installed in a different folder which is entirely possible and OK, if you want to run both version. Just make sure you are launching the version you want. I run a Beta version for shaking out new issues before the next version is released as well as the current production version. If installed in different folders, their settings are completely separate.

Right now, MT Pro will always either start minimized or not, depending on how you have it in settings. There is no way to differentiate whether it is being manually or automatically launched.

I guess you could use something like AutoHotKey as a separate launcher, in that program search for the target window and either minimize it, maximize it or resize it within AutoHotKey. You would then run a different AutoHotKey Program and WIndows startup (that minimizes it) and then you could run it normal using the launch Icon directly. (or visa versa)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

i remember installing the 1.8.4 version in the same path as the previous one and verified after lauching the app in the help->about section that it was 1.8.4 that was lauched. So if the minimizing at startup works as intended, the error is surely on my side. I will investigate next time i upgrade and also make sure to choose a different location like you suggest it. Also will try to investigate with AutoHotkey if it can help achieve minimizing how i wanted next time i upgrade. Thanks you again mister for you detailed and lighting fast responses.

1 Like