Set translator velocity to input velocity

I’m trying to make a translator preset to use for a piano to change the channel, however I can’t figure out how to match the translated velocity to the input velocity as there just seems to be fixed values.

is there any way to do this?

thanks in advance

The field with the values are also drop-down menus where you can set variables. Set the input velocity to ‘any’ and the variable qq. Then set output velocity qq. Means, output is the same as any input.

1 Like

When doing this the translator sends a note off event instead of note on, even when the note on event is selected as the outgoing message

Hi, let see you project file. You do not that a note on with zero velocity is actually a note off, right. That is the MIDI standard. However you can make it send 0x80 (note off) instead of (0x90) note on if you make the outgoing message a raw MIDI message

80 pp qq - Where pp is the note number and qq is the velocity.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

here is the project file, and here are screenshots of the log viewer and also the output into my midi monitoring software

test 1.bmtp (2.1 KB)


In preset 0, translator 0, (0.0),
I added qq as the incoming velocity captures.

In translator 0.1, I did the same for incoming velocity and then made the output note off instead of note on assuming you wanted to pass the same message

I disabled the second preset so the translators no longer will work.

Since the ‘Swallow’ option is set on both enabled translators, the MIDI message will be translated and not go through your defined MIDI thru path in the router.
All other messages will pass through untouched.

I set up my alias as follows for testing:

You can learn more about aliases from this tutorial.

You can see it in action. I also sent note 0x25 so you can see that it passed through untouched.

note-on-off-channel-map-example.bmtp (2.1 KB)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:
1 Like

Thanks for that, this solved my problem, an oversight on my part :+1:

1 Like