Shortcut Breaks Following Key Held Down In A Sequence

I had an idea to make a button held down start a two translator sequence, with deselect (Ctrl + D), and then after a delay it would hold down the “End” key for me. I used to just have the End key by itself and it worked fine, but adding this new Ctrl + D stops End from being held down and I can’t figure out why. No matter how much delay I put on the End key translator.

Hi, Assuming again you are using FL Studio. I see where Ctrl+D is deselect but I don’t see a shortcut for end. Could you explain exactly what you are trying to do in FL studio so that I can test the procedure. Are you also trying to use injected keystroke here?

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

I’m using the / and * keys to move the playheader by bar (whole note).
If you hold down the End key while doing that, it will make a timeline selection too.

So I use it with the push button ticky endless encoders. (Akai Fire and the DJ Controller).
I can move around using the ticky knob. I can hold down the button and then move it to make really fast selections.

It’s shown in my video at 4:13. (Kind of. It’s too dark. Imagine my hand moving the ticky knob.) :sweat_smile:

And at 5:02. In Step Edit mode / and * moves the playheader by grid snap, not bar.

When I send the note up (letting go of of ticky knob button) I have it send a “Home” keystroke.
Because the playheader in FLS will just sit at the end of a timeline selection. So now it goes to the beginning as it should. So I also use pushing the button to deselect and send the playheader home, as pushing the end key deselects anyway, as it expects a new selection to start. (End makes wherever the playheader travels across to be a selection. No movement means no selection.)

But it can’t deselect events in the window (notes or patterns etc.), which is annoying. So I had the idea to have it deselect first (Ctrl + D) on press down, before End, so the button can double as an all deselects hotkey. But it doesn’t seem to be working.

Could I see the translators in question (maybe remove all other translators and just sent me the relevant ones as a project file? I assume you are only talking about outgoing keystrokes from MT Pro and not incoming keystrokes from your keyboard as with incoming keystrokes from your keyboard, the original keystrokes are never suppressed to the application or operating system by MT Pro.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

You might want to try this. They all have the same incoming message with
different delays.
The first translator sends Control key down
The second sends D key down 10ms later
The third sends keystroke End (both down and up) with 15 ms delay
The forth releases D key at 20 ms delay
And finally, the fifth releases Control at 25 ms delay.

It looks good as far as outgoing actions. Of course you will need to have FL Studio focused.

90416430 - MIDI IN [WORLDE easy control]: 90 00 7F
90416432 - OUT 0.0 Key down: Ctrl
90416442 - OUT 0.1 Key down: D, delay:10 millisec
90416452 - OUT 0.2 Keystrokes: End, delay:15 millisec
90416460 - OUT 0.3 Key up: D, delay:20 millisec
90416464 - OUT 0.4 Key up: Ctrl, delay:25 millisec
90416581 - MIDI IN [WORLDE easy control]: 90 00 00

Ctrl-D-End.bmtp (1.7 KB)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Oh no. I had a stop flag on it. :tired_face::sob: sorry for that

But I only found that out because your idea to swap the order.
So I wouldn’t have found it without your help. Thank you.

1 Like

Actually could we add this to my suggestions?
Would be nice if the stop processing flags would appear in the log window.
Just a little “stop” word when it happens, that’s colored red.
You know how many times that would have helped me figure out why something’s not working?

I put the stop flags on there so the computer doesn’t have to think unecessarily,
but now it’s making me think unnecessarily. I don’t like that trade. :sweat_smile: