Simple Timer Test

I tried some MTP files including a timer, my own or from Steve.

The timer always has effect if the test-start button is pressed, but not if the input is triggered. Same result with midi input or key stroke. So I made a simple test file, where the timer input is escape key, and the action (moving the mouse pointer to upper left corner) is triggered by the timer. Also here it works when test-start is pressed, but not when escape key is pressed. Am I missing something?





Either make sure MT Pro is not focused when pressing ESC key or ensure you have “Ingore incoming keystrokes when focused” unchecked as shown here.

Also I found that for some reason when I create a new timer in this fashion. Sometimes I have to restart MT Pro before it takes. Unfortunately I cannot reliable reproduce the problem so until I can (and can report it), I will continue to do this.



Thanks, Steve.

I also found out, that timer work if I avoid using RAW Midi.

If you use raw MIDI, you might need to set the input to variables instead of absolute values and then adjust manipulate the variables if necessary. For instance with Raw MIDI any note 60 on MIDI Channel one will trigger the timer “trigger timer” based on the velocity parameter you add in the rules.

Incoming 90 3C qq

// 60 Decimail is 3C Hex
// This will trigger on any velocity. If you want to trigger on a velocity range of 10-20
// for instance, you would dd this
if qq20 then exit rules, skip outgoing action

Outgoing : Timer “trigger timer”