Timer never receives incoming action?

I have an unusual problem with a timer:

As you can see in the log at the bottom timer “Change Setlist” is fired 3 times with 5 ms delays. Right below the translator are three translators that are supposed to fire on that timer. Usually it works after I close and open the project but after disabling/enabling processing I cannot get it to run at all anymore.

Why are the translators not triggering anymore from that timer anymore?

Project starts disabled and then just waits for BF 77 00 to initialize. It stops after firing the timer for no reason.

03-10-21 Time Issue.bmtp (578.4 KB)

Development done and it is no longer a problem.

However I suspect this issue may originate somewhere when resetting the project after overflooding.


Is there anything still needed here? If you can simplify the situation down to something reproducible, we should be able to help. I didn’t see any issues.

Maybe timer actions also stop after an outgoing action of “Stop Processing” but I’m not sure as I have never tested this. It would interesting to know how you solved this.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

So my little experimet.

  1. Timers keep running while processing is disabled.
  2. The only thing you can do when disabled is to enable. For instance, you cannot stop a timer when processing is disabled. You have to enable processing and then stop the timer.

Here is my simple test file.

timer-stop-processing.bmtp (1.7 KB)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

I don’t think so - perhaps when I run into this issue again I might revisit this topic.

I don’t think disable processing is the issue - from the screenshot Bome has processing enabled (topright corner and rules are processed in the log).

Last thing it does in that log is firing the timers and for some reason they never trigger the translators below.

I usually only resort to posting issues when I really don’t understand why it’s not working or behaving as it does and this was one of those cases. What’s different now and back when the issue occured was that right before restarting the project I had some wrongly assigned controller send a midi message that caused an endless loop. Then obviously I have to ctrl+shift+r the project and try again and then suddenly it won’t trigger “Change Setlist” anymore even when the script is running fine on the next try.