Velocity -


I have a question about the velocity range/value. My velocity value is now about 10 to 80. Is there somebody who can help my with a formule that increase the higher velocity value while the lower value stays the same. So i like see something like 10 to 120.



What you are talking about is "scaling".  Please see if the below video tutorial helps you and get back to me if you still have questions.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi Steve,

thank for your quick response. I did see the tutorial and I still have some questions. The tutorial you sent me is a scaling over a control message and I believe that I need a scaling over velocity. Probably with the same formula only in the opposite way than the tutorial.

My lowest velocity is 8 when I play the piano key's soft as possible and the highest is around 86 (when i am not smashing the piano keys in two pieces). What I like to accomplish with the MTP and a translator setting is the lowest velocity as low as possible (that will be 8) and the highest around 120.

The tutorial explained to decrease the range while i like to increase the velocity range but only with the velocity registration over all keys.

I am lost when it comes to the variable settings in the incoming and the outgoing settings

For example when do i need to use pp and when qq. I get the feeling pp stands for note and qq for the velocity?

So i think the incoming should be:


Midi note message

Note on


any channel (i am not sure if i need to use variable here)

Note trigger

Any note (i am not sure if i need to use variable here)


Any velocity - checked on

set variable to velocity qq

swallow midi message - checked on

So i think the outgoing should be:


Midi note message

Note on


The outgoing channel is that a variable or just channel 1

Note Value or Variable

I am lost here should it be pp?

Velocity Value or Variable

set variable to velocity qq

I put this formula in the rules. (Probably totally wrong)



pp=pp 8

Thanks again Steve for your help!


Hi try this. Here is the formula for note-on translator. For note-off translator, just pass through the value.

Yes, note in this case is pp and velocity (value) is qq


// Scale it
// Output Range 120-8+1 or 113
// Input Range 86-8+1 or 79
// Offset to get to 8 as low note

// Set limits
if qq<8 then qq=8
if qq>120 then qq=120


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:


Hello Steve, thank you for your super quick response. First i followed your instruction and made 2 translators note-on with all the settings include your formula and then the note-off (with pass trough the value). Unfortunately didn't work so thought off course i did something wrong, didn't notice you where so kind to send me your template. So off course downloaded it and opened it in MTP. 

Unfortunately your template also don't work (was the same settings that i made from your instructions).
For some reason the higher velocity will not go higher than 98 (i have to smash my piano keys in two for doing that, :-)) So when i am paying normal it will be between 8 and 86.

My set up is a Yamaha U3 Silent piano with midi out connected to the bomebox, thats connected via ethernet cable to my imac and finaly using ableton live 10 suite to record it. Could it be that the Yamaha U3 internal interface cutting-off the velocity before it sends midi data to the bomebox?

Thanks again Steve

Hi Carlos,


My guess is that your BomeBox has a MIDI thru path set between your piano and the ethernet output port. Please uncheck Automatic routes and delete all existing routes as shown in the the illustrations below and retry. The first illustration is what you need to do. The second is what it should look like when done.




Hi there Steve, yes you where right automatic routes was checked on. So i did uncheck, del all and saved them. I hardly dare to say it anymore but unfortunatly now i dont even have sound anymore. When they are cheched on there is sound only the problem is the velocity (even with your template you send me loaded in MTP) and with checked off there is no sound at all. 

Maybe a bit off noob question but how does the bomebox comminucate if the automatic routes is disabled? Can it be that i am using in MTP maybe the wrong midi in port by project default midi ports? I am using now bome net.

Thanks again Steve for your patience and effort.


Now just make sure your aliases are set up correctly to the input ports and output ports you want. If no thru routes are set, then the translators themselves control the routing to the correct ports.

The below tutorial show how this works with MT Pro. When you put your project file on BomeBox it works in the same fashion.

Tutorial: MIDI Device Selection at Project/Preset/Translator level in Bome MIDI Translator Pro

If you show a screen shot of your BomeBox MIDI ports, I should be able to tell you if the aliases are set up correctly.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi Steve, i did what you told me to do only i still don't hear any sound coming thru. So i'am sure that i'am doing something very wrong so therefor i made screenshots for all my settings, on your advise. Maybe you are seeing whats wrong.

Thank again.

Hereby the screenshots

I don’t see the screenshots. Please hit control F5 on you browser and try posting them again.

Hi there Steve, hereby the screenshots


Attachments still not coming through. Did you hit control-F5 before trying to post them. Also I found if you hit delete after selecting the file, they will not post when you try to re-post (until another control-F5).


Hello There Steve, trying again (with shame because how difficult can it be, hehe...)


Yes Steve, it worked!! Send you some more, just to make sure! And again super thanks for your patience, :-)



Please follow these instructions. We will be using in 2 scenarios. Scenario 1 will be our test environment. Then scenario 2 will be for running on BomeBox (assuming this is yout production mode).

Always use Aliases to make the project file portable. Do not define your input or output ports to the real ports. Please use the aliases as I had them in the original file I sent you

  • My Keyboard
  • Application

The aliases will be assigned the actual physical port names. In MT pro you can do this in the MIDI menu. On BomeBox you can do this on the device selection page.

For Scenario 1, aliases are defined as follows:

Input : My Keyboard -> Arturia Beatstep

Output: Application -> Bome MIDI Translator Virtual Port 1

In your application you would use your input at "BMT 1"

Lets test everything in scenario 1 before moving on to scenario 2.

Once scenario 1 is working, you can upload and run the project on BomeBox. Aliases there will be as follows (after moving your Beatstep to the BomeBox USB port:

Input : My Keyboard -> Arturia Beatstep

Output: Application -> imacvanarandia

Your application input should be set to BomeBox Net to see the network output.

See the attached diagrams.


In your screenshots, it appears you have the input and output set as BomeBox Network, but your BomeBox doesn't seem to have any attached devices or a project file running.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: