Windows Error Using BOME in FL as a VST in Ableton

error checking midi devices

Hi,

So I’m using FL as a VSTi within Ableton Live Lite 11 and routing BOME to both using separate ports (BMT 1 for FL and BMT 2 for Ableton) so that they send different messages within each program. According to other users getting the same message, the issue seems to be resolved when BOME is out of the mix, it being a Windows-related error that checks for MIDI devices when BOME is an active process. Is there any way to troubleshoot this to get rid of whatever conflict is causing the pop-up? Thanks!

This might be because either FL or Ableton Live is trying to open the same port. Make sure you disable Input and Output for BMT 1 in FL and for BMT 2 in Ableton. DAW’s are notorious for trying to open all MIDI ports available in a given system. Usually they can be disabled by simply unchecking them.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

BMT 1 is the only MIDI input port enabled in FL and BMT 2 is the only input port enabled in Ableton, so I don’t think they’re conflicting that way. Is there something else it could be?

Well, MIDI devices should not have changed unless you changed the number of MT Pro virtual ports.
You can try and check Both BMT 1 and BMT 2 at the project level in your Bome Project File so that MT Pro always hold them open. Of course, you will need to define the proper ports you want to use either at the preset or translator level if you do this so that your translators only react to the intended port you are triggering. See this tutorial.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I didn’t have any luck changing the hierarchy, but I wonder if it might have to do with my routing settings at the project level?

midi router

Here’s what I have right now. Would there be a conflict going from application rather than the virtual outs?

Also, I noticed that there were two aliases for this controller when selecting device inputs:

mpk inputs

Should I be choosing one and not the other, or does it make a difference?

Are you plugging and unplugging things while FL is running? The error appears in FL Studio so it may be trying to make adjustments as MIDI ports change. Ideally, you should not change your port configuration once the applications have started or the application should be graceful in the way it handles ports disappearing and re-appearing.

This is hard to tell because it is an incomplete picture. For instance, it looks like you have an alias in play called “Application” which probably points to a virtual port. I’d have to see you alias settings to help much here. Ports with static routing like this are “always open” anyway.

As far as MKP mini 3 vis MKI MKIII, the first is a physical port and the second is an alias which point to the physical port. Usually when aliases are in play you should only use the alias. If you check both, you will get double MIDI messages going to the same port which is usually not what you want.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

No, I don’t touch any of the ports or plug in devices while the application is running. I also tried configuring the aliases to no effect. Still not sure where there could be a conflict. I’ve tried uninstalling hidden abandoned MIDI port drivers in the device manager to make sure Windows isn’t checking for MIDI devices there, still nothing. Would there be something else in Windows outside the DAW that could have an effect on it? Sometimes I’ve been able to replicate the issue by opening Chrome while the DAW is running, which might indicate something interfering from the network side of things.

Hi,
To investigate further I would need

  1. A copy of your project file
  2. An exact description (diagram better) on how you have set FL Studio, Ableton and other stuff with MIDI. I’m a little fuzzy on this from your last description.
  3. An understanding of how your project aliases are set up and which physical ports they are pointing to. You can find this by using the MIDI Menu in MT Pro
    image
  4. Snapshots of your MIDI Setup in FL Studio and Ableton Live
    I don’t have a paid license of FL Studio so since the license is restricted, I’m not sure if I will be able to duplicate that setup and I’m reluctant to purchase a license for $99 USD just for this test so maybe the free license will be enough.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

You might also see if there are any applications that use MIDI. I know I loaded an application call CopperLan that really messed up my MIDI configuration so had to de-install it. You might find suspect applications running in your task manager.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Mobius Rig_Bome.bmtp (18.5 KB)

I have Ableton hosting FL as a VSTi plugin (the first audio track). The other MIDI track in Ableton is for USAMO, but it is not itself a MIDI device. In FL, I have MIDI devices selected (see pic in 4 at bottom) that are for controlling plugins within FL’s side of things, and in Ableton, I have a separate BOME port for controlling things like transport on its UI.

port aliases


Ableton’s MIDI preferences (if you scroll, none of the rest of the MIDI devices are selected)


FL’s MIDI Settings page.

Hope this helps!

P.S. I also discovered that Chrome has a MIDI Web API built in. I disabled it, but it didn’t get rid of the messages. Maybe there are more hidden network MIDI API’s within Windows I could look out for?

Well I suspect the issue is that you have so many MIDI thru paths. I think you should get rid of all of the thru paths and control things exclusively through translators. I suspect random thru path MIDI message are getting through and messing things up. When I removed the MIDI thru path, things starting behaving.

If you want notes from your keyboard to come through as well, just put translators there for note-on and note-off.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Thanks Steve for all your help, I really appreciate it. Unfortunately, it looks like the issue remains despite changing BOME settings. Disabling BOME and still getting the pop-up leads me to the idea that it has nothing to do with BMT and is an error I must resolve through FL or Ableton. Take care.

Yes, I agree. You may be able to further troubleshoot it by using a different DAW than Ableton and seeing if the problem follows. If it follows, it is likely a FL Studio issue and if it does not, it is likely an Ableton Live issue.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like