Windows keyboard as additional input

This must be easy but I cannot find the solution anywhere in the manual or online.

I have a project where I use a Arturia BeatStep as my midi input which works great, but I would like to add my Windows keyboard as an input source.

The keyboard does not appear in the choices for midi input. The Event Monitor does show activity on Keystroke in, but when I specify keystroke in there is no output.

So how would I specify my windows keyboard as a midi input??

Hi, Bome MIDI Translator does in fact recognize keyboard input. You do not show it available as MIDI input because the keyboard is not a MIDI device. To convert keystrokes to MIDI, you set up individual translators with the keyboard input you desire (as incoming action) and the resulting MIDI output and destination you desire to translate from the keyboard input.

A very simple Example
Input: Keystroke physical key A
Rules: None
Output: Note 64 MIDI Channnel 1 velocity 127 to Bome MIDI Translator Port 1

If you have a specific scenario that you have tried but are struggling, please provide information on a simple case of the desired input and output and I can assist further here.

Steve Caldwell
Bome Q&A Moderator and Independent Bome Programming Specialist.


Thanks for the reply. That is excactly what I thought… So just trying this out. I wanted a Preset change but used the first key on a UK key board left of the 1 with the following characters`¬¦ on the key Bome registers it as ` but when I test this it does not work.

If I replace this with an A keystroke than it works. So now I wonder why the key with `¬¦ does not work?

Hi, it should work. Make sure you either do not have MT Pro focused when pressing the key or uncheck the option (screen shot below).



Hi, I am struggling with a similar problem, new to Bome Pro. I want to send midi note messages to Cubase via Keystrokes, have set up a patch with all the requisite connections as per your directions above, but the commands reach Cubase unaltered. I am suspecting the port routing is at fault, have tried all possible configurations, but no dice. Thanks for any pointers

Hi, could you please post your project file as a new question and I will have a look and see what might be happening. Also a screen shot of how you have MIDI input set up for Cubase.

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist