BOME MIDI Translator and Roland RD-2000

It looks like your tranlsators are looking for CC0. Maybe you should change the incoming to CC7 on each translator (each with different incoming channel as you have it).

Steve Caldwell
Bome Customer Care

Also, make sure the preset is enabled. I may have inadvertently disabled it prior to posting the project file.

Yes! the preset was not enabled! :-) But enabling also doesn't work.

Changing the input CC still give me back CC7

Is possible that the RD-2000 don't allow to split the faders with different CCs?

I attached a screenshot with the things I changed for Fader 3 that I want to send CC21


Make sure Studio One MIDI is only Monitoring your BMT virtual port and not your RD-2000 directly

Your screen shot for that translator shows you are looking for CC21.

Yes… but instead, C22, when I move the facer I get CC#:7

You are not changing the value of the incoming faders. You just want to interpret the incoming value and change the outgoing value. Maybe check the MIDI OUT box in the log file? With that said you will not see Outgoing, unless you have a matching “Incoming” trigger (which will be CC7).

I think I start to understand. :slight_smile:
Thank you very much, Steve, and sorry to be so annoying. Now is working.

The faders work perfectly now, but The Mod wheels that have CC1 and CC11 configured on the Keyboard directly doesn't work if I only activate like MIDI IN BOME MIDI Translator 1.

Works with the RD-2000 but if I keep both active, the faders send both CC7 and the CC I chose with Bome MIDI Pro...


I downloaded the project I created that you modified with the \"Suppress all other CC\'s\" and I get 8 note on and 8 note off commands in Studio One.

Studio One doesn\'t have any monitoring or direct connection to the RD-2000 right now. I have changed the RD-2000 input inside Studio One to only accept from BOME MIDI Translator 1.

When I setup the project you modified for me, I set all channels looking for CC0 because that\'s what I set my RD-2000 to do (changed from the default value of CC7 to reduce conflicts since I use CC0 for nothing in my DAW Projects).

So still in this project, my faders work great. I was even able to add another translator to add my Modwheels since the surpress also blocked those. No big deal, they work now as well.

It\'s just this 8 note on and 8 note off message for every key stroke that\'s the killer right now. If we get that figured out, I should be well on my way and will decide to go for pro version instead.

I am attaching screenshots of what Studio One can see as well as the logfile from BOME. You can see BOME see\'s 8 note ons and 8 note off commands and is sending those to Studio One.



To add some information to this, it appears that the RD-2000 sees each of these faders as a separate zone. To be able to use each fader, you have to “turn them on” one by one and when you do, you either tell each fader it’s for “External” or “Internal”. when you set it to external it gets its own zone number 1 through 8. Each time I turn off one of the faders I get one less note each time until finally, a single fader setup gives me one.

Hopefully there’s a way around this or to tell BOME to reduce those messages it sees from the keyboard to maximum 1 regardless of it seeing 4 or 8, if that even makes sense as the way to correct this.

Put everything through your Bome MIDI Translator 1 Port. Add translators for the Mod Wheels. Anything that comes in through the original RD-2000 port will not be processed by MT Pro as you are bypassing it by receiving MIDI through the RD-2000 port.

Could you show me the log window in Bome MIDI Translator Pro with all boxes checked. Are you sending a note (pressing a key), on your RD-2000 when you see the 8 notes?

Here is the screen capture of the log viewer when it happens. I am actually hitting a key to make it happen. In this instance, you're looking at the results of me pushing down middle C 1 time and letting it go.



I added translators to allow notes on MIDI channel 1 only and then to suppress notes on any other MIDI channel. You can change as you want if you want notes on other than MIDI channel 1.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:



See my latest posting with translators to suppress notes on anything except MIDI CH1.

So far so good. I put in my modwheel translators and it works great.

This is really great that it’s allowing me to use the faders on this beast. I think my final thing to tackle is how I am going to handle the fact that I have a 1500 track template and obviously not everything is channel 1.

I have to say, that I just tested it and came back to edit my original answer here. It works for all midi channels even when I switch to an instrument on say MIDI channel in 14. I simply don’t know how that’s possible. I see it sending MIDI channel 1 but it somehow works. It even works in a VE Pro template where I might be sending to an instrument that’s on VE Pro instance 3 channel 15. I simply have no idea why it works, but it does.

How is it possible that it works for all my other MIDI channels, no matter what channel they are programmed on or if they are local or remote in VE Pro?


That’s great!
maestro2be, could you share your file with the modwheels translators? Is the only point that I am trying to figure out how to do. Thanks!

Hi, The faders of all channels are now handling Volume of MIDI Channel 1 only. I'm not sure how the RD2000 handles "zones". From what I see a zone is a channel but maybe I'm wrong.


Anyway, glad to see it is working for you!


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi Steve,

Buying now MIDI translator Pro. Not only looks an incredible piece of software but most important is the support you gave us. Really, 10 of 10. Thanks!

Waiting if maestro2be want to share his final file with the mod wheels translators. (Maybe could you give me advice about how to create the modwheel translator?)

MIDI Translator Pro turned my RD-2000 in an even in a better keyboard. ;-)

I am a photographer so in the future, I am wondering how I will implement MIDI translator Pro in my workflow.

Thanks again!