Bome Network for Raspberry PI

Any chance we could get a disto of Bome Network PRO that could run on a Raspberry PI?
I am a solo musician and refuse drag around a laptop as part of my rig. I control backing tracks and lighting via a Raspberry PI mounted in my rig. It would be so nice if I could trigger my tracks and lighting via a virtual midi port running on the Raspberry PI over a WiFi network with a Bome box on my pedal board.

1 Like

Hi and welcome to the Bome community!

Unfortunately, we do not have a Linux distribution of Bome Network. However you could purchase a BomeBox that could be used for fundamental MIDI routing and if you also purchase Bome MIDI Translator Pro, you could develop a more complex project (with dynamic routing and translation) on a Windows or Mac PC and then load and run it on BomeBox with or without a computer. You can also network BomeBoxes together if you would like.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

PS: the BomeBox also acts as WiFi router or connects to an existing WiFi router.

Hi, we have just released Bome Network 1.5.0, with versions for Linux and Raspberry Pi:
If you give it a try, please report back how it works for you. It requires a reasonably current Raspberry Pi OS. Thanks!

1 Like

I have been unable to install the package on my Raspberry PI 4. Sorry for my ignorance, but how to install? There is only one file in the download zip package called ‘Bome Network’. The filename has no extension. What type of file is this? If I try to install the file using ‘sudo apt install -f’ command, I get an ‘Unsupproted file’ error. The OS my Raspberry PI is running on is Raspbian GNU/Linux 11 (bullseye). Running in ‘armv7l’ 32bit mode.

Hi @reboard , thanks for trying!
The file is just a plain executable, so under normal circumstances, you should just be able to run it by double-clicking it from a Nautilus or other file explorer. However, due to a bug in the file command, which is used by Nautilus, double-clicking does not work:

The next release of Bome Network for Raspi will be compiled in legacy (-no-pie) mode so that you can launch it with a double-click.

For now, you can launch it from a command line with this command:

./Bome\ Network&

The Download file “Bome Network” is actually an executable and doesn’t need installing. Just run it from the shell. I run it in the background with the below command (assuming the executable is in the current directory)

$ ./Bome\ Network &

I am also running bullseye.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks so much for the quick response. That was very helpful. I have been able to get it running and configured to auto start. Now in the process of getting it configured.

Just a suggestion. You may want to include in the zip package a properly configured .desktop file and a readme file that explains were to copy the files to. Command line options. How to set proper permissions on the files, etc. This would help getting up and running quickly for those of us that are a bit novice on the Linux OS.

Thank You,

Thank you for the suggestions. We decided against including a .desktop file because that depends a lot on the Linux distribution / window manager. This is a general problem for a readme file or similar: different Linux distributions have different conventions where to put executables.

We figure that there are two types of users:

  1. Users who will unzip it using a file manager like Nautilus and just double click the file to start it. They can also use the file manager to copy the executable to where they want it. This does not work with the current version of Nautilus due to the mentioned bug in the file command. It will work with the work-around in the next version of Bome Network.
  2. Users who usually work on the Linux command line. They should know how to start the unzipped Bome Network from a shell and move it to a location of their liking.

Yes, we will document them and add some more command line options for expert users in future.

1 Like

Hello, I am new to raspberry pi and linux. can you please give again exact instructions how to get bome network running under raspberry pi. sorry, i cant get it to work.

  1. Download the file into a directory on your Raspberry pi
  2. CD to the folder name
  3. Type this command at the promt
    “./Bome\ Network &”

Bome Network will then start and you will be returned to the prompt. If you get an error, you may need to do an update to your Raspberry pi

apt-get update
apt-get upgrade

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Dear Steve, thank you that worked. I was on a 64bit version when I tried first. I want to use raspberry pi with an app called Mixingstation, which can control a whole lot of live mixing desks. My plan was to integrate a midicontroller with it. unfortunately mixingstation is only available in 64bit for raspi.
Do you happen to know if there will be a 64bit version of bome network for raspberry pi?

Thanks so much again.

Hi Andi,
thanks! We didn’t know that Raspi/64 was in much use at all! We should be able to provide a 64-bit version with the next release.

On the other hand, a 32-bit program should work on a 64-bit Raspbian. You may need to install 32-bit compatibility libraries.

dear florian, thanks so much for your answer. such good news. I will try to find and install these compatibility libraries. thanks so much again!

I really managed to start bome network 32bit in the 64bit raspi after installing a lot of libraries but only without gui. is there a set of instructions you can provide. for example how do I confirm connection to the bomebox in the shell? or setup virtual ports, or put in my licences? sorry, I am a noob.

Hi Andi, that’s nice to read. Without GUI, however, Bome Network cannot be used (at this time, version 1.5.2). You will need to find out, somehow, how to see the GUI…

I managed to get the gui and the bome network seems to work as expected, I can connect to other computers and the bomebox.
sadly the programm ( does not see my controller (x-touch) through the bomenetwork, it does not see any midi ports from there. the x-touch is only visible when I connect it via usb to the raspberrry pi.
thank you again!

Can you see the X-touch from the operating system or any other applications when it is connected over Bome Network? Did you check and see if you have Remote Direct MIDI selected for you remotely connected device?

For Instance, this is how my computer sees my BomeBox devices from my PC although I’ve only enabled my XKey37. At the operation system level it is seen as “BomeBox2:XKey37”.
The switch has to be turned on as shown.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Dear steve, thanks for the input, I have now tried with activated remote direct midi on but the x-touch ports are not visible in the mixingstation app. for now I will have to use the usb-connection.

OK, does the mixing app support 32 bit? I have a 32 bit rpi that I could try with.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: