Can't install v1.84

Hi Steve,

I tried updating to v1.84 and got an error message that the installer couldn't delete awt.dll from the Program Files (x86)/Bome MIDI Translator Pro/jre/bin folder - pretty sure that's the path. Anyway, I couldn't delete the program myself because it was supposedly already open in BMT, but I wasn't running BMT - confirmed in the task manager.

As administrator, I was able to move it out of that folder, but another file then prevented updating. I moved that also, plus a bunch of other files. Still no go. Then I tried to move additional files (in the lib folder) but couldn't even move them out of that folder.

So now, I'm at a standstill. Can't run BMT Can't install it.

What should I do?



Hi Gabriel, can you go to Programs and Features and when you find Bome MIDI Tranlator, uninstall it from there? If so, do that and then start a fresh installation.




I’m on Windows 8. So is that the same as uninstalling a program in the Control Panel/Programs? I tried that. That’s the first time I saw a potential problem, because I got the message that some files couldn’t be removed.
It did uninstall the program, but now, I can’t install v 1.84 because some files it needs to delete are undeletable (is that a word?)

Try restarting Windows 8 and then after that immediately (open no other programs) go to Control Panel/Programs and try to uninstall again. If that doesn’t work then try to go to the CMD prompt (Launch as Administrator). Then delete everything in the path C:Program Files (x86)Bome MIDI Translator Pro
Again do not start any other programs prior to trying to delete the files in that path.


I did shut down and boot again, but will try once more. When you say CMD prompt (Launch as Administrator_ is that the same as selecting Run , which asks me to type the name of a program folder document or internet resource and Windows will open it for me?

If you already did uninstall just do step 2. You should be able to delete the files after a restart if you have not opened any other programs that have used them. You may have to run CMD prompt as Admin to do so however.

How do I get to CMD prompt. Sorry… I probably used to know this, but can’t remember

The Run CMD does not give you an option to launch as admin. Right click on the CMD ICON and then select run as adminstrator.




What you’re suggesting is essentially what I did. Not from a CMD prompt, though. Anyway, I get the message that some files can’t be deleted because they’re open in BMT. But BMT isn’t running.

So… to be clear, I”ve shut down, rebooted, gone into file explorer and navigated to the BMT folder in program files x86 and tried to delete the contents of the folder, but am told that a file can’t be deleted because it’s open in BMT. BMT isn’t running. I haven’t tried to do it from the CMD prompt cause I don’t know how to do it.

Try removing files in %APPDATA%Bome.

I have C: Icon on my desktop and also in the start menu. Right click on that and you should see something like the attached picture.



Or you can follow this procedure
Press Windows+R to open the “Run” box. Type “cmd” into the box and then press Ctrl+Shift+Enter to run the command as an administrator.

How do I open the elevated command prompt?
Click Start.
In the search box, type cmd.
Right-click on cmd.exe and choose Run as Administrator. If done properly, the below User Account Control window will appear.
Click Yes to run the Windows Command Prompt as Administrator.

Where’s %APPDATA%Bome

Go to file manager and in the title bar type %APPDATA% and the ENTER.
Then you can find the Bome Folder from there.

Deleted Appdata Bome… found it somewhere. No change
Will try rebooting and trying cmd prompt again. Got partway through but didn’t see cmd.exe to right click on

I got as far as Run as administrator. When I click on it, I get the prompt C:Windowssystem32. I can’t figure out what to do from that point.

Did the Windows +R thing and thencmd and then Ctrl Shift Enter and now I have the prompt cUsersGabriel. STill don’t know what to do from there.

I’m able to right click on Run as administrator. When I do, I see a black window with C:Windowssystem32>
Don’t know how to then delete the files I need to delete. Do I somehow navigate to the Programs x86 foleder etc etc and then find the files.. How then to delete them