Controlling my Atem Mini even better - nanoKontrol2 and Behringer Xtouch mini


in this pandemic I came into Videostreaming and I’m doing this with an ATEM Mini Pro.

I’m using an Behringer Xtouch mini with ATEMOSC and Osculator to control preview, Cuts and so on.

One thing ATEM OSC does not support is the Fairlight audio section, I found out, that ATEM supports the Mackie Controls form my XTouchmini to control the Main Fader and the pan.

The ATEM just takes any Mackie Inputs - I have no possibility to Choose an input interface or something like that.

After that I bought an NanoKontrol2 to use that one in Mackie Mode to control my Audio Section in the ATEM Software.

It works, BUT:
I have 8 Faders on the NanoKontrol - none of them wants to control my Main Fader - I would like to redefine them, but I can’t find out how.

The Faders 1-4 are controlling the Camera Inputs 1-4, but when I touch the Fader for the first time they also seem to trigger the “AudioFollowsVideo” Function wich makes it useless.

Also if I use more than one of these first faders they are doing wierd stuff with the AFV Function
Like here around 1:20

Can Bome help me to get rid of these Problems?

I thought I would like to switch the NanoKontrol2 into MidiCC Mode and translate these messages inte Mackie Control -> but I can’t find out how?

Any other suggestions?

best ruebyi

As you know, the NanoKontrol2 only has 8 faders so if you want a master fader, you might need to do something with one of the buttons to switch one of the faders to a master fader. This can be done with Bome MIDI Translator Pro.

As far as the “AudioFollowsVideo” feature, I’m not sure if we can do anything about that depending on how ATEM implements Mackie MCU. Certainly the person doing the video recommended that you don’t try to move more than one fader at a time an he pointed out thinks go quite crazy when doing that.

If you don’t like the way that NanoKontrol2 implemented Mackie, we can certainly put it into a CC mode and the put a project file together to translate from CC to Mackie, or we could look at how the NanoKontrol is sending Mackie commands and modify it using Bome MIDI Tranaslator Pro if it makes sense for a given function. I’m thinking a press of the “set” button or a double press of one of the other buttons to put fader 8 in and out of “Master” mode.

The attached is an example of this. First I put the NanoKontrol2 into Mackie (Ableton) mode by pressing set marker and stop while applying power.

I set up an alias for my Mackie Application. In ATEM you set this for your incoming MIDI device (BMT 1 or whatever virtual port you have assigned within MT Pro).

The way it works is this.
There are two translators. The first one will toggle the global value of variable ga each time you push it. Without pushing it, fader 8 acts just like fader 8 and everything passes through untouched. However pushing set once will turn fader 8 into a master fader. Pushing it again will put it back to fader 8.

For any other “unusual” behaviour, you will probably need to capture the incoming MIDI message in the MT Pro Log window so we can see what might be going on.

Korg-Nano-Mackie-Mode-2020-12-01.bmtp (1.1 KB)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thank your very much!

First of all I didn’t realize, that there are more Mackie Modes - thanks for that.

Thanks you for the example!
It’s just a small problem: The Data won’t be send to the ATEM Software.
Blackmagic does not allow me to decide to wich MIDI Input it should listen, so in the end it seems like it is putting the Nano in higher Priority than BMT…

I can see in the Logwindow that the MIDI Output changed, but the Software still fades Channel 8, not the Master channel.

OK, you might want to check with BMD to see if you can assign a different input MIDI port to the ATEM software. Of course if you are reading directly from the nanoKontrol2, then nothing will change. Maybe if you open Bome MIDI Translator before you open ATEM, then the ATEM will no longer try to read the nanoKontrol and will try another MIDI port (hopefully a BMT port)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

And to the “Strange behavior”:

That’s whats happening when I start to move the Slider on Channel 4 (one of those that messes around)
1: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: 90 1B 7F
2: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: 90 1B 00
3: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: E3 01 01
4: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: E3 02 02
5: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: E3 03 03
6: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: E3 04 04
7: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: E3 05 05
8: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: E3 06 06
9: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: E3 08 08

It seems like the first to lines activate the Audio Follow Video Funktion…
This only happens when I use the slider for the first time after leaving it alone for about 5min.

Slider 5-8 do the same, but there is no Audio Follow Video Function, so it’s not a problem.

OK, I believe this is the touch and release fader command. Try putting a translator that
ignore 90 1B qq

Incoming: 90 1b qq
Outgoing - None
Options : Swallow

I don’t have my Mackie notes handy so don’t remember what note 1B does.
E3 xx xx is fader 4 movement so that looks OK.
Fader 1 should put E0
Fader 2 should put E1
Fader 8 should put E7
Master sends E8

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Ok, it seems like that helps in BMT to ignore the command.

But the ATEM is still reacting to the Nano, not BMT.

So if I would put the NanoKontrol into CC Mode the ATEM ignores it.
But then I would need to map every CC Command to the correct Mackie Command in BMT.
And I’m not sure where to get those command from…

OK, please check with Black Magic Designs if there is a way to define which MIDI input you can select. If they have it hard coded to a given controller name then we will be out of luck. Maybe they changed their ATEM software since they released ATEM MINI? I have not seen this issue before.
The reason I said to load the project in MT Pro before opening ATEM software is that ATEM software will not be able to open your nanoKontrol2 if MT Pro already has it open so maybe ATEM sofware will try to listen somewhere else?

Thank you once again!
I fear it’s hard coded - I tried different Controllers with the same behavior.

Even after a Reboot with starting only BMT - testing the Midi In and output - an then Starting the ATEM Software ATEM does not react on the changed commands, but uses the Native ones.

OK, not much you can do here except maybe talk to BMD.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

the funny thing is:
If I quit Mackie Mode, I can use atem OSC to control my ATEM Software, because my Midicontroller does not use Mackie Commands.

That’s why I asked wether I could translate my normal midi Commands to Mackie Commands.
This should allow me program any button just as I would like it, or am I missing something

I think the fairlight module (which handles mackie) is completely separate from everything else.

OK, Time flies by and I had the chance to use a BCF 2000 with the ATEM Mini and it worked out of the box… I’m still not sure wether I would like to buy one or stick with the nano - the nano is so much smaller, but the bcf has motor faders…

I managed to do something now: Sliders 1-8 work properly on channel 1-8 with my nanokontrol in Cc Mode

slider 1-8 gehen.bmtp (6.7 KB)

I found the basic script in this forum and played around a bit.
Now I get working Sliders, but I’m unable to integrate the toggle Fader 8 to Main function into it.

I also found another problem: I don’t get feedback from firelight. if I use any slider in Software and then on the midi controller the software will jump to the last Hardware Fader position - is there a way to change this?

Well I have a few suggestions.

  1. Rename Preset 1 Controller to Premier to Controller to ATEM (to avoid confusion)
  2. On preset 1, override project defaults so you are looking at BCF for input only and your virtual port to the ATEM for output.
  3. On the translators in Preset 1, remove all rules and make outgoing Ex qq qq where x is the fader number. You will get more complete range of motion. Right now you have Ex qq pp
    4)Change alias “Adobe Premier” to “ATEM” and then assign your virtual port to that

I’m not quite sure what you are trying to do with the master fader switch, but Fader Master Move should work your master fader. If you only have 8 faders and want to toggle fader 8 between master and 8 then, etable preset 2 then on 2.1 change incoming from MIDI Control Change on MIDI CH 1 CC 7 and outgoing the same as you have on translator 1.7 (after modifying it as describe above)
Then translator 2.0 will toggle the use of fader 8 as the master fader with note 60 as the incoming trigger to toggle it.

Also in preset 2 after enabling it make sure you also assign the input and output aliases.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:
1 Like

Thank you for your help!
To make it clear, I tested an bcf, but I’m using now my Korg again.

Today I loaded BMT again and today no reaction in the ATEM Software… it’s frustrating…

MCU Mode still works, but I’m not able to skip the “Touch” order

Well I’m not sure how Black Magic Design (BMD)s chooses a given MIDI port, however if the physical MIDI port is not available (IE If Bome MT Pro has already opened the port), then BMD will not be able to and may just poll various available ports until it gets the response it needs from a given port. You should really check with them on how they pick the MIDI port.

With that said, I would recommend you load your Bome Project file before opening the ATEM software and select the NanoControl2 port at the project level for both input and output. This will open the ports in MT Pro and make them not available to anyone else. Then if the ATEM software is polling ports, maybe it will recognize the Bome MIDI Translator Port that you are using in your project instead.

I’m sorry I don’t own an ATEM or the ATEM software to test this theory for you.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thank you! It works now!

Next Steps would be - Translate the Mute Button to Mackie Control and Translate the Knob to Pan or Gain.

How did you end up getting it to work? Was it by my suggestion or some other means?

I used the File i uploaded earlier, applied the changes you suggested and it worked.
I assigned the MIDI in and out of the NanoKontrol to BMT.

After a restart of BMT it stopped working.
What helped was to Launch BMT and ATEM Software, after that I had to unplug the Nano and plug it in again - with both software running => it works!

I tried this two to five times and could reproduce this behaviour, so it seems like I can rely on this

Now I’m struggling in translating the Knob roation into Variables for Mackie Control

OK, this will be a bit difficult in CC mode. It would likely be better you go back to Mackie MCU mode and use the knobs that way.

You can check our video on converting absolute to relative.

For Mackie, a right turn of the knob is relative 01 02 03 04 05 for each turn depending on how far you turn.

For left, it is 0x41 0x42 0x43 0x44 0x45 depending on how far you move left.

Since encoders on the nanoKontrol2 are not endless, it is a bit difficult any way you go but using Mackie Mode takes less work. I’m not sure though how the ATEM software would handle things.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:
1 Like