Copy/Paste between projects

I can’t copy/paste between projects? I ‘saved as’ and after two hours of work, found all my old work in my old project for some reason. Can’t copy the translators over?

Here is what I do

  1. Turn of the option (Allow only one instance).
  2. Open both projects
  3. Then copy and paste

When done it is probably good practice to turn on only allow one instance again.

Steve

Ya well that isn’t working because it keeps crashing. I think MB has something to do with it. Anytime I click on the MTP icon on my windows toolbar, it never opens.
If I use FL Studio’s launch program feature or click on a MTP project file, it will open. But it will give me the port selection pop up every time, regardless of what I do.

Trying it with two instances doesn’t work at all, even with the ‘allow only one instance’ unchecked. Just keeps crashing. Now won’t open at all.
My dj controller would sometimes stop sending MIDI. I check the project and the output ports show (error) without an explanation for it. Restarting the computer usually fixes it. Happened several times now. These bugs are mounting.

Since you use many keystrokes, maybe it would be a good idea to disable all presets before copying and pasting. Perhaps one of the outgoing keystrokes in interfering with the copy/paste operation.

PS. Yes also make sure MidiBuddy is not running.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like

Ok, well I got it to work with your two instance solution. After ten tries of it not opening, restarts, sweep of the computer, registry scan, virus update, immunize and computer scan for malware, spyware and viruses.
I’m starting to think the ‘start minimized’ feature of MTP is buggy. If I have that enabled, I can’t open the program at all, no matter the circumstance.
I’m going to clean up some iCue macroes and try and use less of the strange characters as outputs. Thanks again.

Yes, my guess is the various keystrokes you had programmed and the fact that the mouse if flooding MT Pro with MIDI postioning messages was interferring with project editing operations.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Ok so can you give MB an input port, and it will keep the mouse position data to itself until MTP requests it with a translator? Could this be in the list of future updates?
It would make it so much better. 99% of the time, the user is not currently pushing a macro button, so MTP has no need of knowing the mouse position. So MB is just wasting processing and destabilizing MTP.
Of all people I would think it would be you who would understand and be sensitive to this design flaw.
I don’t mind paying for an update like this that would be extremely helpful, same with the other ones I asked about before. Just was not working cause of 2020, so haven’t had the money yet.

I’m not at my normal system right now but check the readme file that came with MIDIBuddy. There is a key sequences you can use to pause MB from sending mouse data and then resuming. Since you were doing more serious editing, I was just suggesting you shut it down during the editing process.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Yes, I usually close MB when building the MTP project, unless I need to test some macroes out.
My request is for using these programs after I’m done editing. For all situations, MB would not send to MTP unless MTP asks for the mouse position. I don’t like MB cramming data into MTP for no reason.

You can always suspend mouse message until you need them. Then send the unpause message when you want to know the current mouse position. I’m not going to redesign MIDI Buddy. Just not enough demand for it.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Ok, I’m not sure how to suspend just mouse messages; is that the same thing as suspend MTP processing?

Quick question about the platters slow down formula: Their output is a keystroke.
All the other translators are working properly, but these ones seem to alternate between working and not working. Anytime I first open FLS, they don’t work. If I restart the project and fiddle around, they usually start working.

By “working” I mean that I’m watching the MTP log window and the translator isn’t outputting the keystroke. But after a restart or random actions I take, go back to look at the log, and it is outputting the keystroke. I’m not sure why it’s arbitrarily outputting or not outputting. Don’t know what I’ve changed in between.

I know it needs to log a number of ticks before output, but I can spin and spin the platter forever with no output at all. Then it suddenly is outputting no problem.

Well there are 2 types of mouse movements.

  1. Provides absolute mouse position
  2. Provides relative mouse movement

By defaulft Cntl-Alt-P will freeze Type 1 (along with mouse clicks) and Cntl-Alt-U will unfreeze

For type 2 You use Cntl-Alt-F to toggle on and off the messages.

So if you Control-Alt-P and Cntrl-Alt-F both will be paused.

Note the Alt key is the “Special” which can be re-defined in the MIDIBuddy settings window.

I use the global variable gm to determine how many clicks of the platter have occurred. In the project file I set it to 0 so it will take 6 clicks initially to make the platter movement to register in either direction (based on what you told me you changed. I had it set to 4. Changing the variable uu in translators 11.3 through 11.6 will affect this. for each movement type. If you change uu in 11.3 then you should change it in 11.4 to be the same.
If you change it in 11.5, you should change this in 11.6 to be the same.
It basically says "don’t send a MIDI message until uu number of clicks).

Now if it is set to 6 and you move the platter 3 right and 3 left, it will never register. It has to be 6 right or left in your case, so maybe you have adjusted it with too little sensitivity.

It is also possible that this formula should change

if gm<0 then gm=gm+64.

Instead of 64, it should probably be a multiple of uu so if you set it for 6 clicks, maybe use 36 instead of 64. If you set to 5 clicks maybe 25 and so on.

Maybe you could just comment out that line to see what happens. My purpose for it was so that it would not go up or down some huge number but maybe it really doesn’t matter because essentially I’m only using the remainder to determine whether to send a MIDI message or not.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Ok. Some of my processing struggles may or may not have something to do with me sometimes forgetting that I had suspended MTP processing with my macro shortcut key. I cannot deny or confirm that.

I have corrected that by adding a lighting effect on my keyboard that toggles on a little slow red blink on the key when I push the ‘suspend MTP’ key. So if something isn’t working, I can look down to see if there is a glowing red button.

As for the platters, I had the uu up to as much as 12 at one point. Brought it down to 8, which is a nice calibration. I didn’t know it would cancel itself out from one way to the other. That’s not good.

The remainder of the logged ticks are discarded, aren’t they? If not, should it be using a local variable instead? If I have it set at 8, spun the platter a bunch and had 6 or so left over, it only takes 2 ticks to trigger the outgoing the next time I use it? That would mess me up.

I do know to change both clockwise and counterclockwise uu values in sync with each other. I could see how it would get wonky if out of sync.

The left platter sends out arrow keys. I didn’t know that the FLS arrow key movement is based on the current grid snap setting. On ‘bar’ it’s pretty fast. But higher resolution like ‘step’ or even ‘off’ is a crawling slow pace. ‘Off’ moves by the ppq, which I usually set to 96. It’s very helpful though for nudging notes and other events. I have the Ctrl, Shift, and Alt keys buttons I can push and it will hold them down for me and use the platter. Very nice. I’m very happy with how it’s turning out. As long as I can keep it stable. Haven’t cleaned up iCue keystrokes yet, but I will.

MIDI Buddy wouldn’t open on launch as it usually does. Platters didn’t work. Restarted project twice. MB launched and started working. Then the platters started outputting properly. But the logger window started to freeze after the first window of data and kept doing that after clear. Haven’t seen that before. There is something seriously wrong with MB.

MIDI Buddy is working fine. I’ve extensively tested it. With that said, you can really mess yourself up if you use it incorrectly. Double check how you have your “special” and other keys set and be sure you don’t use the same keystrokes anywhere else in ANY project that MIDI Buddy uses. Also make sure MIDIBuddy is not telling Bome to generate these keystrokes unintended.

Some examples.
You move your mouse and MT Pro sends a keystroke that suspends mouse movement. No more mouse movements are sent.

You move your mouse and MT Pro sends outgoing to suspend MIDI processing. Guess what, nothing will happen from there.

Just a few examples.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Here is a list of keys to avoid when using MIDIBuddy. This is in the readme file.

Keyboard Shortcut Summary

Key

Alt(Default) will still send MIDI message but suppress normal mouse button/wheel
activity. Does not suppress mouse movement (see Ctnl-Alt-F below). You can
change the Key in MIDIBuddy settings to be Alt Left Windows, Caps Lock, Cntl or Shift. You can also reverse the behavior (see Cntl-Alt-R) below.

Cntl-Alt-D

Popup to change the delay of mouse movements in milliseconds. System default is
500 ms (1/2 second) This will also change the frequency of mouse relative
movement messages when the mouse is frozen. This change is temporary (only the
current session). You can make this persistent across sessions in MIDI Settings.

Cntl-Alt-F

Freeze Real Mouse Movement. A tooltip pops up showing that the mouse if frozen.

Cntl-Alt-P

Pause Mouse Movement and Unique mouse click MIDI messages (Toggle - If on will turn off. If off will turn on Pause) System Default is unpaused

16-Aug-2018 - This can now be changed by setting PauseModifier in the INI file

PauseModifier=^!T

BE CAREFUL to NOT use something already assigned.
The above example is Control-Alt-T

Cntl-Alt-Q

Quit MIDIBuddy

Cntl-Alt-R (Toggle)

Reverse the behavior of the Key. Normally, if key is no not
held down, both MIDI messages are sent and actual mouse action occurs. When
held down, only the MIDI message is sent without the Windows mouse
action. Now if you type Cntl-Alt-R, the behavior is reversed. Type Cntl-Alt-R
again puts MIDIBuddy back into normal behavior. A pop-up screen is shown if in
the reverse behavior to remind user of the reverse mode and how to get back. Note
that reversing the behavior on you mouse also reverses the behavior coming from Bome
MT Pro and any other application that sends mouse and keystroke combinations.

Cntl-Alt-U

Unfreeze Real Mouse Movement

So I’ve gone through iCue and my MTP project with a fine tooth comb, and all the available FLS keyboard shortcuts. There is nothing in any of my shortcuts that conflict with MB’s shortcuts.

These are the MB hotkeys that are suspended when I ‘suspend hotkeys’? I always have them suspended, because the mouse won’t click on things if it isn’t.
I’ve changed the special key to windows, instead of nothing. So there is something there. I’ll just avoid the windows key. Have the mouse action delay to 0.

Think I’m going to have three MTP virtual input ports. One for Launch Control, One for Traktor Controller, one for MB. Also will have three output virtual ports, and so these controllers will have their own dedicated pathway. Is that a good idea?

Otherwise, I’ll just get rid of the iCue special character output and just deal with little issues as they arise, and just keep swimming.
Thanks again.

I think I have the mouse action delay by default at 500ms (1/2 second) to reduce the MIDI traffic.

1 Like

You mean when I trigger a translator, it waits half a second before executing it?
I don’t think that I’ll be wanting to make shortcuts take longer than necessary.
How does it reduce MIDI traffic?

No, I mean that MB sends MIDI messages only ever 500ms so that it doesn’t flood MT Pro with MIDI messages.

1 Like

:open_mouth: :open_mouth: :open_mouth:

:smiley: :smiley: :smiley: :grinning: :grinning: :grinning: :smiley: :grinning: :smiley: :grinning:
YEEEES YES YES YES
Now we’re talkin! I didn’t know that.
Thought it was for delaying an action before a mouse movement.
Now that I think of it, MB doesn’t control when MTP sends a command to the mouse, so that was dumb.
Thank you, that’s awesome! :grin:
Now I’m in business.