How to make nanoKontrol2 play button light blinking in sync with the tempo of my DAW?

Hi everyone,
i’m asking for a little help:
i have done all the translations that i wanted with my nanokontrol2 and all is working fine. The only thing that i cannot figure out is the question on the title. i want to make blinking the play button light of the nanokontrol2 like when it is routed directly to the DAW, so when i press play the light blink in sync with the tempo. When it is routed to Bome midi Pro then routed to the DAW, the play button lights up but don’t blink. Any solutions?
Thanks in advance


This may or may not be possible. You would need your DAW to provide MIDI Timing Clock output if it is capable, then you could count timing clocks and blink the LED every 24 clocks (for a quarter blink), 48 clocks (for a 1/2 note blink) etc. You would need also to have something to tell what the time signature is as well and which clock tik is the down beat is. to blink the LED. I suppose if your DAW sends MIDI start and stop commands you could figure the downbeat (but not time signature) from there.

If timing is provided by some external source and not the DAW and the DAW is slaved on the master then of course you would use the master clock for all of this instead of the DAW.

I hope this helps!

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Another possibility is to set up a track on your DAW to send out a note message (on an unused channel so that it won’t be heard) on every downbeat and use that signal from your DAW to blink the LED.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks again for your lighting fast reply Mr Steve !
I’m using FL Studio 20 and it sends timing clock. When i use that as incoming source, i have the same result: The button lights up but don’t blink. The time signature is always 4/4 and downbeat is when i start the DAW. I thought that it could be possible to achieve with a timer but apparently not. When i tried i get some random blinkings. So i suppose that there are some scripting in the nanoKontrol2 profile that make possible to achieve blinking in sync when it is routed directly to the DAW. It was quite some time that i was trying to figure out how but i think will be a little complicated to achieve with Bome Midi Pro. I’m going to try your suggestion but at the end i think that it’s not a big problem if the light is not blinking.
Thanks again

You would

  1. Need to disable any normal LED feedback coming from the DAW
  2. Set up a translator to count the timing clocks and send note on on every 24*4 beets.
  3. I would suggest turning the note-off after the first 24 beasts and then wait 24*3 to send a note-on again.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks, i will try your solution to see if that does the trick !

On the nanokontrol you have to set the device to use external LED control. It’s handled by the nanokontrol application.

Once you’ve written the data change to the controller it “should” retain it. Until then you cannot control the LEDS.

See LED mode.

Thanks ARC,
but this is already done and the LED is working properly. When the nanokontrol2 is choosen as midi output the LED blinks fine in sync. It’s when it is routed on a bome virtual port, so that’s what is choosen on my DAW that the blinking is not working but the LED work still.
The solution by Mr Steve will propably work but i don’t know how to set up a translator count timing clock as all i got as option in incoming source is timing clock (i’m still on version 1.8.0 maybe the option is available on latest versions?). I think i will give up on this one and focus on music since it’s not that crucial.
Thanks for your help

1 Like

@Newcomer , wait, you say it blinks when directly connected and only stays steady when connected through Bome MIDI Translator Pro? Other than changing the port in FL studio, do you change anything else in FL Studio. Could you:

  1. Show me a FL Studio screen shot on how you have it configured directly.
  2. Show me a FL Studio screen shot on how you have it configured with BMT 1
  1. Post your project file
  2. Show me a log of activity in BMT when you push play (check Incoming, Outgoing, MIDI IN and MIDI OUT

If configured properly, we should be able to ensure the default behavior still works with MT Pro attached without adding any translators to add timing clock.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks Mr Steve,

i will try to provide that quickly but basically i’m pretty sure that the configuration is set up properly:

When i use directly the nanoKontrol2 with FL Studio, the midi output is the nanoKontrol2 and the LED blinks in sync with the tempo when i press play.

When i use a virtual port to output the midi (correction: it’s not a Bome midi port but a virtual midi port created with loopMidi that i named FL Studio), the midi output is FL Studio and the translator in Bome Midi Pro is set up like this :

incoming port : FL Studio
incoming source translator : timing clock or F8 in raw midi
output port : nanoKontrol2
output destination translator: Note 10 on channel 14 and velocity of 127 (that’s the note that is configured in the Korg Editor that lights up the play button LED)
So when play is pressed on FL Studio the translator works as intended (i have the midi events working) and the play button lights up on the nanoKontrol stays steady. And i think it’s a timer that is needed to send note off (to turn off the light) then note on on a synced period of time to make the button blink in sync.

#Aha #ApologiesThere !

1 Like

If it works with FL Studio direct, you should disable the translator and just put in a MIDI thru path from your LoopMIDI port “FL Studio” to your nanoKontrol2 port. (no translator needed).

With that said, if other MIDI message coming from FL Studio to NanoKontrol2 need to be blocked, you might need to put some blocking translators that have the incoming message that needs to be blocked and outgoing message of None with swallow set.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

No problem, thanks for trying to help!

Thanks Mr Steve for that advice. I have already use the midi router in Bome midi pro to route the FL Studio port to the nanoKontrol2 port but for some reasons it is not working. The Play LED don’t even lights up on the nanoKontrol2 that way and i’m scratching my head why it is not working that way because i use the midi router for another instrument ( a midi keyboard this time ) and it works fine…

Could I have a look at your project file?

Yes of course, i’m sending it in some minutes !
The project is sent, thanks for looking into it.

OK, I see that you have input ports set for Both FL Studio which I think is your LoopMIDI Port.
You also have a thru path from LoopBE Internal MIDI to nanoKONTROL2. What is that used for?

It is used as input port in my DAW. On Bome Midi Pro my translator is set up this way:
incoming port: NanoKontrol2
outgoing port : LoopBe
so in Fl Studio it is LoopBe that is choosen as midi input.

The midi thru with LoopBe is to to send back to the nanoKontrol2 what it is sending to my DAWs because i use other DAWs like Pro Tools or Samplitude. It is intended to turn on and off the lights of buttons pressed on the nanoKontrol2.

Yes, however if you have LoopBE as incoming MIDI as well, anything going out to your DAW via translator will come back into LoopBE and be sent to NanoKontrol2 as well

NanoKontrol2 → Translator → LoopBE
LoopBE → MIDI THRU Path → NanoKontrol2

In this way the MIDI thru path may be interfering with what you are getting from FL Studio. I suggest you remove the thru path from LoopBE Internal MIDI bak to your nanoKONTROL2

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: