suddenly my project won't load

After my usual workflow of making some changes to input notes in a couple of presets in BMTP, I uploaded the project as always, but suddenly there was no output. I upload the file, then do "select" as always, and everything looks right. After investigating, though, I see that the MIDI ports page says "no project." The BomeBox input DIN is set to my controller as always and open, but BomeBox DIN output is closed, so there's no MIDI at all passing through. When I go back to the Translator page, I then see my project isn't active, so I select it again, but the same situation continues. I've tried restarting my BomeBox, but I don't know what else to try. When this happens, BMTP shows input with no output, then when I close the project in the BomeBox's web page, the project functions correctly from inside BMTP.

I'm attaching my project here and appreciate any troubleshooting help.




I got it to work again. It seems that, at one point, the MIDI Ports page started letting me make choices after I uploaded a toy project. When I went back to the real one, it was working, and the BomeBox DIN output no longer showed as closed. I'm attaching a screenshot of that page--it's correct, right?


The question is: what might have thrown things off in the first place? All I did was a minor tweak, then suddenly the output DIN can't be opened. Can the port settings suddenly get hosed from some sort of bad communication? I hope I don't have to just write this off as bad WiFi conditions again. At this point, the BomeBox is sitting on top of stuff, three feet from the computer, which has line of sight to the box. I do have that latency issue when using BMTP, which isn't a terribly big deal in my case, but is it possible my BomeBox's WiFi isn't up to standard? I really don't see how my environment's WiFi is much different from other studios'. Is there a specific quality test for the BomeBox's hotspot?



I tried loading your project onto a BomeBox and got the message attached. This usually means that the signature is not correct, that you are uploading after editing in an unlicensed (trial) version of MT Pro or that you modified the contents after editing in MT Pro (which will invalidate the signature).


Did you do any editing to your project file outside of MT Pro?  If so, after doing your edits, reload the project into MT Pro tool, then re-save it so that it gets the correct signature, then upload it and try again.  I've included a copy of the file (with my licensed signature) if you want to give it a try.

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist


No editing of the project file outside of MT Pro. How do you even do that? In any case, that same error has popped up for me 2-3 times, then it just goes away. I just assumed your software phones home to authenticate and network conditions well known in my region caused the foulup. But if you’re experiencing the same error, what could account for it? I’ve only ever used BMTP because I bought that along with the BomeBox.

OK, I made a cosmetic change, then re-saved and am uploading my project again here.


Hmm, the only other thing I can think of is an incomplete of the project file. But the chances of you and me both getting an incomplete upload is pretty low. Maybe a bad spot on the computer hard disk created a corruption of the file in the signature area which would still allow the project file to load and execute on your PC.

Yes the project file can be opened in a text editor. I do this once in a while if I want to do global search and replace. It is a bit dangerous to do though since global search and replace is dumb and may replace things you don’t want to replace. Also the format of some of the file although readable is not that user friendly for editing. If you ever edit it outside of MT Pro, first make a backup copy and then when you are done editing, open, save and close the edited file in MT Pro to ensure the signature is updated for BomeBox execution.


It’s possible I had the demo version of BMTP installed before I actually installed Pro. I just can’t remember, but I can’t rule it out. Could some weird artifact of that cause the authentication error? But then, how could it also happen on your computer?

In any case, has the second upload worked? I’d still like to know the source of this odd behavior where the output DIN suddenly gets shut down. It’s the first time that’s happened, but that is an impactful glitch.

I don’t remember ever seeing a situation where the DIN ports showed closed. Did you see that as well? I assume you are using the latest version of BomeBox firmware.

Yes, the MIDI Output BomeBox DIN showed “closed,” and there was no active dropdown menu. I just re-verified that firmware is 1.4.1.

The only time I think the DIN port would show closed is if you have a project that is not using it. I just tested this with a project that I have that doesn’t use the DIN port.

I only have the one project, and in my setup I’ll always use that DIN. In fact, due to the latency problem over WiFi, I’ll never be able to use my BomeBox with software modules.

Also, if your alias is not-assigned or not assigned to the MIDI DIN port, the MIDI DIN port would also show closed. When you close any projects it should show open again which is the default configuration if no projects are loaded.

I’m periodically experiencing similar problems with my modified and signed project file, so I’ve escalated your case. In my case I no longer get the bad signature message, however the project file will not restart unless I reboot my BomeBox. Stay tuned.

Remember that my lone project and its workflow were working fine when suddenly I got the closed port situation. There’s just nothing to account for this glitch, and also recall that the Ports page of the web interface started showing no project was loaded even though the Translator page showed otherwise and then would show not loaded later so that I’d have to “select” again. One other symptom when this glitch happening: when I’d do the “select,” there was a particularly long latency before the notes stopped playing through BMTP. Normally, as soon as I select, all latency disappears and I can see BMTP’s log window no longer registers activity. While the glitch was in effect, BMTP’s log window would continue to log input for at least 30 seconds, and I was able to play the controller until it would suddenly go silent.

I’m running MacOS Catalina, by the way.

Yes, I remember but thanks for the reminder!

Any word yet? The problem has gotten worse for me. Now, every time my BomeBox restarts, there’s no MIDI output. I have to start Bome Net on a computer and go in to manually do the MIDI setup every time.

I’ve tried replacing that project with a much smaller one that uses the active presets from the original one. Same problem: select doesn’t survive a power cycle.

Hi, we are looking into it and will let you know when we find something. This is an unusual issue and we have not seen it before. Fortunately it is still running after a reboot. We understand that it is impactful and appreciate your patience while we try to figure out what is happening.

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist

OK, thanks. If I try something myself in the way of troubleshooting, I’ll post that info here in case it might be useful to the people helping behind the scenes. I understand that you don’t need to respond specifically to any small update I might post. If you have any small tests you’d like me to run and report the results, I can do that, too.

OK, the approach I would recommend is to start disabling and removing functionality until the problem disappears. Then we could compare the working file with the non-working file and perhaps it would give us some clues.