Using Presonus Faderport to control Cubase Quick Controls


I just installed the trial version of Midi Bome Translator and was hoping to make this work but I can't get it running.

Here is what I would like to do:

I'd like to use the motorised touch sensitive fader of the Presonus Faderport to control channel one of the Cubase Quick Controls.

I got instructions by email from Florian which I followed but it isn't working.

I think the problem is that I have 2 messages coming in: Touching the fader (I think its note on) and the fader movement (I think its pitchbend)

Is it possible to get this working and is it also possible to get touch control working so I only write automation when touching the fader? Also is it possible to send the midi from Cubase back to the Faderport so that the motorised fader follows the Quick Controls?




Hi Jorg,

Could you please post your project file and I will have a look. I will need to determine what CC’s your Faderport is sending for each fader you wish to use. I assume you are putting Cubase into Mackie MCU mode and not Mackie HUI mode. I would need to know either way.

I’m also assuming your Cubase “quick control” that you want to move is is a fader? If not, I will need to know the MIDI message it expects and the message that is sent from the FaderPort fader you are using. The former you can test by looking at the log of incoming MIDI messages when you move the control on Cubase. The latter you can test by looking at the lo of incoming MIDI message when you move your Faderport fader.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist


Hi Steve,


thanks for your quick reply.

I have attached the project file.

this is the message coming in from the Faderport:

292: MIDI IN [PreSonus FP2]: E0 00 47
293: IN 0.0 Pitch Bend on ch. 1 with any bend set ‘pp’ to bend=9088
294: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: B0 80 00 B0 A0 7F

Cubase quick controls doesn’t actually use Mackie Control or HUI. Its a set of 8 controllers that can quickly be set to control anything in Cubase. Cubase allows you to set a hardwire controller for these quick controls. I attached a screenshot.

I can manually enter what message is coming in. When I use “Learn” mode it automatically thinks its a note on message which I assume is me touching the fader rather than the pitch bend from moving the fader.





Something like the attached should work.

Please set up your aliases when prompted

From FaderPort, To FaderPort (these should the device name that your FaderPort creates when attaching to your computer.

From Cubase, To Cubase (these should be whichever virtual port you are using on Cubase.

At the project port I have all ports open.

I have to presets. The presets override the project default.

Fader to CC – From FaderPort To Cubase

CC to Fader – From Cubase to FaderPort

Each preset has one translator. The Fader to CC will convert your Fader into CC 60 for use with Cubase.

The CC to Fader will convert CC back to fader going back to your Faderport (If Cubase sends this).

Let me know how it goes.




Hi Steve,

thanks so much for your help.

The good news is there is now signal going from the fader to Cubase. There is nothing coming from Cubase going back to the fader.

Also the signal that arrives in Cubase seems to be wrong. I recorded what happens when I only move the fader from top to bottom once. So this was just one fader movement all the way down.

Instead of just closing the filter once its seems to do it over and over again.




Try setting the output of Translator 0.0 to qq insteand of pp. See screenshot lower right area. On your version it will say pp.

Can you use the MIDI translator log to see what is coming back from Cubase when you move the control within Cubase?



Great, thanks. The fader runs normally now.

Only problem I have is that every time I touch the fader it also sends a note on message because its a touch sensitive fader. If there is an instrument on the track it actually plays it as a note. Is there a way to stop that?


This is the message coming back from Cubase:

7714: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 71 00
7715: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 70 00
7716: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 6F 00
7717: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 6E 00
7718: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 6D 00
7719: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 6C 00
7720: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 6B 00
7721: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 6A 00
7722: MIDI IN [Bome MIDI Translator 1 Virtual In]: E0 69 00


These are the messages by the way the Faderport sends when touching a fader and when letting go:

19693: MIDI IN [PreSonus FP2]: 90 68 7F
19694: MIDI IN [PreSonus FP2]: 90 68 00

OK, you will have to create a new translator to suppress this message
Incoming: Raw MIDI 90 68 qq
Outgoing: None

This is coming from your quick control? If so, you need to relearn it. It looks like your quick control is also sending pitch bend.

I think I had it wrong. I think this is what’s coming from the quick controls:

635: MIDI IN [Bome MIDI Translator 1 Virtual In]: B0 3C 48
636: IN 1.0 Control Change on ch. 1 with CC#:60 (0x3C) and any value set ‘qq’ to value=72
637: MIDI OUT [Bome MIDI Translator 1 Virtual Out]: E0 48 48
638: OUT 1.0 MIDI E0 48 48

That looks correct,. Do you have your Alias FaderPort assigned to your actual Faderport device? It looks like you have it assigned to Bome MIDI Translator 1 instead of your actual faderport device.

Is the FaderPort plugged in. If not, the motorized fader will not move.

That was it. All working now!! Thanks so much!!

You are quite welcome!

Just need to buy the full version. 20 minutes won’t be enough 🙂

Well now you know it will work.


I can’t get this to work anymore and was wondering if you could help me again please?

It worked fine last time and haven’t used it in a while and now it doesn’t work at all anymore.

I have attached the Translator file I’m using and the screenshot of the case setup.





Ignore that. In Cubase I have to set the “Track Quick Controls”, not the “VST Quick controls”


Working again!

I just bought faderport 16. I am impressed that you got it working with Cubase using bome midi translator pro
Can you kindly share the setup in Cubase, as well as the bmt project setup. I appreciate your help
I have tried many thing but I am not able to get Cubase to feed midi data back to faderport so that the faders reflect the midi setup