Allen&Heath dLive /w Cockos Reaper CC control volume automation, NRPN

I trying to make a fully automated project for a timecode based theatrical show to keep my hands free.
All the channel fader levels are automated and prepared in the DAW.
CC channels of variable values are being sent to bome box to get converted to NRPN messages for the dLive console.
I am confused with MSB and LSB, what parameter is what?
According to the AH manual ( )
as an example for Channel 26 (hex 19) at midi channel 2 (N=1) it should be
B1 63 B1 62 17 B1 06 LV(value).

It is a simple task but I’m stuck with it… would appreciate some clarification.

Best regards,

Their tables are confusing as it is unclear for some things whether to use hex or decimal, but this is how read it. Also they use the term Channel for both MIDI Channel 1-16 and tracks 1-96

I believe the MSB is the track number-1 and the LSB is the parameter number (Fader =0x17 or 23 decimal)

Then the values (assuming they are 7 bit) should be passed through as the same value as the incoming fader.

Give the attached a try.
CC-to-NRPN-dLive-Fader-Track26.bmtp (980 Bytes)

I don’t have a dLive to test it with.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Steve, thank you for your help.
Unfortunately I feel like I got some mistake in the midi routing and just something is wrong and doesnt go through. I’ve tried all kinds of combinations, watched all of the youtube tutorials but completely frustrated. Now in Reaper the midi output is Bome Net. Nothings happening at the console, although I had DAW control driver working before and something else moved a few times during Midi device reset. This is an alien technology level for me, please help. :frowning:
Spent the whole day and night.
Uploading: IMG_5921.jpg…
Uploading: IMG_5920.jpeg…
Uploading: IMG_5919.jpg…
dlive again.bmtp (1.3 KB)

Are you running the project file on BomeBox or on your computer?

If on the computer, you will need to route from your computer to your dLive within BomeBox and then set. You will need to tie a virtual port to the output port used in Reaper and then route using the same alias as in the project file I sent you. and use your BomeBox for the ouput port. See screen shots.


I recommend you run it this way, since Reaper doesn’t have any virtual MIDI ports. You can still use Bome MIDI Translator as as a static MIDI router to connect to your BomeBox or you can use Bome Unlmited Virtual MIDI Ports, if you have purchased that.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Reaper is on my PC connected to a dlive with a Bomebox in between. I am loading the project file through the browser into the bomebox.
My confusion is mostly with the virtual ports and the routing, as I understood the path must be connected both ways through the virtual ports for the translator to work or it can be just PC to dLive? And while using the Bomebox we skip the AH DAW driver, is that correct?


Ok, now I got the bome routing looking correct. What driver do I choose in reaper, dlive, bomenet or the windows midi? I’m very new to midi, more into mixing, just hope to get through this.

OK, I think to start, it would be better to run you project file on the computer since you can look at the log there while you are developing your translators. After that is done, then you can upload your project file to BomeBox and use there if you want to offload MIDI processing. I’m going to reverse my initial decision to put add a route on your BomeBox and instead use Bome Network’s Remote MIDI Port capabilities.

If you click on your BomeBox in the Bome Network tool (in my case, "BomeBox2). You will see the attached ports to the BomeBox.

Click on the switch to expose your BomeBox dLive to your PC directly (no BomeBox routing needed). In the diagram, it is the bottom switch and it was initially red and clicking on it made it green.

Now in MT Pro you should see the port as your BomeBox name followed by a colon and the port name for your dLive.

However do not connect there, yet use the alias in the project that I created. This way later, if and when you move your project to your BomeBox, you can just re-assign the alias to the port name presented directly on your BomeBox.


IN the MIDI Menu Dropdown you should have the following option. Edit Project Port Aliases.


Here is how I have my aliases set up in my project file (running on Windows PC).

Clicking on it will open a popup window as show. This is how I have set my aliases.
The main thing here is to ensure that Reaper output is set to the same port as your project file. It may show, however to Reaper as BMT 3.


For me I’m just moving the first fader on the DAW, although you could probably use track output to do things as well. I’m assuming you might use Automation in Reaper to move your dLive faders.

Under the Control/OSC/web section in preferences this is how I have. It, I used the BCF 2000 driver as it seems to put out simple MIDI CC messages.

Here is the detail when clicking “Edit”. Right now I don’t have anything set for input since we are simply sending CC messages to Bome MIDI Translator to convert to NRPN which is needed by the dLive.


Now when I move fader1 in Reaper I see this in the Log Window of Bome MIDI Translator.


I don’t have an actual dLive, however I have an emulator that Allen and Heath provided to help with this tutorial. Here is what it sees so I know the messages are flowing completely. What I am not 100% sure of is if the NRPN output is correct for what the dLive expects. I referred to the documentation on that so I think it is right.

Once you get everything working with the project on your computer, you should be able to upload it to BomeBox. In this case you would use your output from Reaper similar to this.



After activating the project on BomeBox, you would assign your aliases like below:

Now I don’t need the project running on my PC and the path is as follows

Reaper → BomeBox2 Net → MT Pro Running on BomeBox → dLive3

Again, I recommend you get everything running with the project on the computer first, so that you can troubleshoot. Once everything is working, upload and assign the aliases and redirect Reaper output to your network port.

Here is the updated project file.

CC-to-NRPN-dLive-Fader-Track26.bmtp (843 Bytes)

Good Luck!

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:
1 Like

Steve! Thank you very much!!!
I did everything step by step and it worked. First checked on the computer and matched the CC values, then loaded the project to BomeBox.
Now I can empower pure alien technology after almost embracing darkness :smiley:

The only weird thing is that the hex number value is actually +1 off the A&H table.
For example for CC=82 in reaper is actually 83 on their table. (using MIDI channel 2)
LSB is Parameter, MSB- input channel (for those who will try this at home)

I sent MIDI commands using Repers ReaControlMIDI plugin through FX and then added a MIDI out in the channel routing.

After that I added this FX envelope track and copied my volume automation envelopes to that track.

The only question left- how do you add a formula or rule to the translation to change the linear value to logarithmic?
At the moment the fader sensitivity is the other way round.

CC_nrpn_dlive_test1 (1).bmtp (837 Bytes)

THANK YOU! It is a miracle.

Best regards,

Hi, the attached example provides a simple velocity curve. I created it some time ago so haven’t studies that math recently. I believe that the key values to change is ga in the first translator rules.

This is what it looks like if you set ga to -100


This is what it looks like if you set ga to +100

And the project file
Velocity-Curve-Example-2022-01-11.bmtp (3.2 KB)

Oh and I’m so glad you got it working!!!

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:
1 Like

Actually the curve is ok, it is the Reaper’s envelope scaling.
When I copy the volume automation to a CC track the scaling isn’t really correct (by default with max envelope value +6db) the cc when pasted does this:
Volume automation 0db > CC envelope 63 (instead of 107)
When doing +6 (to the max of the scale) it goes all the way up to 127 (which is +10db).
Changing envelope scaling in Reaper just makes it a different story. (if you copy paste from volume envelope).

So I did a small adaptive rule

if qq<62 then qq=0
if qq>=62 then qq=qq+44
if qq>121 then qq=121

This way Reapers 63 has dLive take it as 107 (0db)
And maximum is +6 (I dont need a bigger value).
I hope this comes useful for people searching for similar tasks.
CC_nrpn_dlive_zheka.bmtp (896 Bytes)

Ah, I see. We have a tutorial on how to do scaling in Bome MIDI Translator.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: