MIDI CONTROLLER for FAIRLIGHT (DaVinci Resolve)

Hi, I’m a new user of BOME MIDI TRANSLATOR PRO, I need to configure my MIDI controller (behringer bfc2000) to control the volumes of the audio tracks in FAILIGHT (DaVinci Resolve). Can anyone help me or link a video tutorial on the setting to be made? Thanks.

Hi, and welcome to the Bome Forum!

Davinci Resolve Fairlight uses Mackie MCU for fader input, but only 8 faders plus a master. A bank or track up or down message is required for handling additional faders/knobs.

They all use pitch bend messages

Fader 1 input should be (in hex)

E0 mm ll - Where mm = most significant byte and ll is least significant byte

Fader 2-8 would be E1-E7 and the master fader would be E8.

Here is an example of CC 0 on MIDI CH 1 to fader 1 output

Incoming: B0 00 qq
Outgoing: E0 qq qq

Note we populate both the LSB and MSB with the same value since incoming is 7 bit value and outgoing is 14 bit value. This gives us the full range for the fader (but with less precision).

Some applications also require “touch” and “release” messages but I don’t think Fairlight does.

If this doesn’t move your fader 0, let me know and I will tell you what the touch and release messages look like. Since I don’t think your BCF 2000 has touch sensitive faders, we might need to just send touch and release messages before and after the fader move messages above.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I tried but it doesn’t work. I managed to insert button for the “SOLO” of track 1 and it is OK, but the FADER does not work. I attach the file. Fairlight.bmtp (1.2 KB)

Try this,

Fader touch is Note 0x68 (104 Decimal) to 0x70 (112) decimal.
Touch is value of 0x7F (127) and release is value of 0

The project sends a touch at the beginning of every knob movement and release at the end.
Fairlight-sjc.bmtp (1.2 KB)

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Does not work. This is the FILE LOG that appears if I move the FADER from the bottom (- infinity) to the top (+ 10db) with the mouse. It can be useful?

log.zip (895 Bytes)

I don’t see any MIDI in from your BCF2000 do you have it selected as an input device? What I see is the output of Davinci Resolve assuming it is coming in on Bome MIDI Translator Virtual 1. They certainly look like fader movements.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

@SteveC I’m looking to do something similar, trial user here (but will pay if it works). I have DaVinci Resolve 17 and would like my M-Audio Oxygen 61 midi controller to control the faders and mutes of the Fairlight virtual mixer. I downloaded the .bmtp file you posted but I don’t understand it and my first fader didn’t move. I posted what I changed the preferences to as an attachment, my midi controller also shows up too. But selecting that as the In and Out didn’t automate the fader either :frowning: Thank you for your help!

What is the selection list for the Audio Console where you have “None”? I’m not what this is and I cannot get Davinci Resolve to open on my PC. It seems that it always installs and works the first time but fails every time I open it after that. I’ve checked the Black Magic Design forums and the only advice I have found is to re-install it which I don’t want to do every time I want to use it.

I’ll crack open my Mac and look at it there later. In the meantime, the best thing to do is open MP Pro and turn on logging for MIDI IN and MIDI OUT to see what is happening. I suspect either MT Pro alias is not set up for Bome MIDI Translator 1 or that port is being used elsewhere. If you can capture the log and post it here, I will know better.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi, I was able to get it working on my system. Just make sure that BMT 1 is selected for both input and output in Davinci Resolve and that no other applications are using those ports. Also I noticed that when you re-open Davinci Resolve, it seems to forget what ports were selected so you may need to do this every timer you open Davnci Resolve. Make sure you start the Bome MIDI Translator Project first though so that Davinci Resolve does not try to capture your controller ports directly.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I’m also really struggling with this.

Not sure why it’s so difficult though, but just had a note in from Curtis Judd saying that he had also abandoned attempts to get them working.

I’m probably being very naive but I would have thought that there might be a set of mappings somewhere that says Ch1 fader = CC16 and that I just map CC19 from the MidiMix to that. I’m guessing that it’s a bit more complicated with needing to send raw message like “B0 68 7F E0 qq qq B0 68 00” and I feel I should be able to work this out somehow, but I can’t find any sort of target map for Fairlight anywhere.

Have I completely got the wrong end of the stick here?

Thanks

Mark

Hi Mark,

First you need to make sure that Davinci (Fairlight) is looking at the correct port. I would set it to BMT 1.

Fairlight uses Mackie which is not CC so you will need to convert CC to Mackie which is why there is raw text. In your case if fader 1 is CC16.

Set incoming port to MIDIMIX and outgoing to Bome MIDI Translator Virtual 1

Incoming: Control Change 16 on MIDI CH 1 any value set to qq
Outgoing: Raw MIDI 90 68 7F E0 qq qq 90 68 00

I’m afraid B0 doesn’t work so I may have made a mistake in my previous post. 90 68 7F signals that you have touched fader 1, 90 68 00 indicates you are no longer touching it. This is necessary since MIDIMix doesn’t have touch sensitive faders.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Brilliant, thank you very much Steve. That works perfectly for Fader 1.

The highly predictable follow up question is which bits do I increment for the other channels?

91 68 7F E0 qq qq 91 68 00 doesn’t work for Ch2, neither does 90 69 7F E0 qq qq 90 69 00.

I’m guessing now that there’s some universal Mackie definition somewhere for each MIDI command?

Thanks again.

Mark

Notes for faders 2-Master (in hex are)
Fader 2 - 69
Fader 3 - 6A
Fader 4 -6B
Fader 5 - 6C
Fader 6 - 6D
Fader 7 - 6E
Fader 8 - 6F
Master Fader - 70

Instead of E0 use E1-E8 for faders 2-Master

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Excellent - thank you. That works well for the 8 faders and got you an appreciative sale.

I’ll post the file up here later so that others can benefit.

How do I find out what the other mappings should be? E.g. for Mute & Solo buttons, for Pan controls etc etc?

Thanks again

Mark

Try this link

https://r.search.yahoo.com/_ylt=Awr9BNcrOYNg60wA7WdXNyoA;_ylu=Y29sbwNncTEEcG9zAzQEdnRpZANDMTYwOV8xBHNlYwNzcg--/RV=2/RE=1619241387/RO=10/RU=https%3A%2F%2Fstash.reaper.fm%2F2063%2FLogicControl_EN.pdf/RK=2/RS=CAFNvBmowokz9w28z_geo7tfMtE-

MidiMix → Resolve v1.2.bmtp (6.4 KB)

Thanks - that helped and I managed to get the Faders, Mute & Solo buttons all working with the LEDs and attached the file that works with the Akai MidiMix in its vanilla config.

Still not managed to work out the Pan controls though.

I thought the Pan L-R control message is B0 30 qq where qq is a range of 01 to 0B

The sliders go from 00 to 7F so I’ve translated a series of trigger steps. E.g. when i/p B0 12 0D is detected then send B0 30 01.

It’s triggering OK on the detection and I can see that the MIDI message is being sent, but it’s not changing anything in Resolve. Similarly, when I put that message on a button, nothing happens. So it looks like I have the incoming message trigger OK, but not the outgoing Pan controls.

I’ll keep digging & experimenting.

What you are describing is the VPOT rings and MIDIMix doesn’t have LED ring feedback.

For sending, a Mackie MCU VPOT sends B0 1x yz

Where x is the VPOT Number 0-7
y is 0 for clockwise movement and 4 for counter clockwise
z is the movement amount.

So in essence, the output is relative and not absolute.

Since the MIDIMix sends absolute only, you need to track the last known position in a global variable (1 for each VPOT) and compare with the last known position to determine the output value. It is best to center your knobs when starting the project.
With that said I added a suppress function in the attached project. Pressing Bank Right will suppress the outgoing messages (setting ga as suppression flag to 1)
Releasing Bank Right will stop suppression.

I also added some multipliers near there right and left ends if needed if you MIDIMix doesn’t provide full range of V-POT motion (since the pots are not endless).

MIDIMIX-VPOT1-2021-04-24.bmtp (2.0 KB)

The rules are commented

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Excellent. Many thanks for that, makes more sense now.

Have attached the latest MidiMix bmtp file for anyone else that might find it useful.

It now has:

  • Faders 1-8
  • Mute 1-8 with LED Feedback
  • Solo 1-8 (on the Rec Arm buttons) with LED Feedback
  • Pan 1-8 on the lowest row of knobs

Thanks again

Mark

MidiMix → Resolve v1.3.bmtp (13.9 KB)

Great, I’m glad you have a working project new!

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like